Hyperlinks in the reference list

Is there any way to prevent EndNote including URLs in reference as hyperlinks in the reference list at the end of a paper.  It’s a pain to have to remember to remove them before submitting.  I just want the URL to appear as regular text, not a hyperlink.

This is a Word processing “feature” and not controlled by Endnote. 

Edit Word’s Autocorrect settings  “Autoformat as you type” (and “Autoformat” although changing the first seemed to removed this behavior in my test right now in X7) deselecting the “internet and network paths with hyperlinks” will prevent the URLs in the bibliography from being turned into hyperlinks.  

These settings are in different places in different versions of Word.  In 2010, they are in the options (from “file” menu) - then autcorrect, where there is an “auto format” button, and from there to the settings tabs for the individual types including those for “Autoformat as you type” and “Autoformat”.  

I think these settings are applied to just the current document unless you edit the normal template to make it “stick” on all new documents.  You may have to investigate the settings options for word in more depth to figure that out.  

Many thanks, Leanne - I will try that

I agree that Word can be the culprit with its autoformatting “feature.”  However, even within EndNote X7, if I click the Preview tab, the URL is turned into a hyperlink.  In fact, even when I type in a URL manually into a reference field inside EndNote (not in Word), by the time I type the second slash after http:, EndNote has turned it into a hyperlink.

Although in EndNote I can select the hyperlinked URL and press CTRL-T to change it to “plain text,” the preview in EndNote still shows it as a hyperlink.

It would be really helpful if there were a way to turn off/on in EndNote the “feature” that automatically turns URLs into hyperlinks.

Does anyone know how to do that?

I don’t think there is a way.  Even if the preview shows it as a URL, inserting it into a Word2010 document with the autocorrect turned off does not. I can’t imagine when I wouldn’t want to be able to “link” from the Endnote program to a URL “live” – so I guess the developers couldn’t either.  

Apparently I was deceived by EndNote X7!   :manembarrassed:

When APA 6th style is selected, EndNote’s preview shows the URL as a hyperlink.  However, if one uses “Copy Formatted” or if one uses File/Export to RTF and then pastes into Word or opens the RTF file in Word, the URL is actually not hyperlinked in spite of what EndNote’s Preview panel shows!  :mansurprised:

So much for Preview!  :manfrustrated:

I think you’re right Leanne:

@leanne wrote:

I can’t imagine when I wouldn’t want to be able to “link” from the Endnote program to a URL “live” – so I guess the developers couldn’t either.  

I guess *I’m* the odd guy who expected the Preview to be one of those times when you didn’t want a live link but an actual Preview of what the reference would look like formatted in the selected style!  :manwink:

Anyway, thanks for your help and I hope this info helps some other poor soul who might have different expectations for how the Preview panel ought to display previews of the reference.

Endnote has no way to “check” the settings of a Word document which isn’t in use - it doesn’t know where it is going to be inserted or what the word settings are?   – so I think it shows the most and not the least of what will end up in a document.  

Fair enough, but if I manually marked the URL as “plain text” using CTRL-T inside of EndNote, shouldn’t it remember that and show it as plain text in the preview?  While I agree that Word could change that “plain text” URL into a hyperlink if Word’s autocorrect settings are set up to do that, wouldn’t the fact that I manually changed the URL to plain text suggest I want to override how EndNote thinks it will look in Word?

Ah well.  I’m OK just carrying on knowing the preview is different than what I’ll get when I copy it into Word.

I guess the up-side is that I don’t have to manually change the URL to plain text at all, so, that saves me some trouble!  :manhappy:

1 Like