Terrible Endnote X3/Pages 09/snow leopard bug


I ran into the same problem. So I saved my file in its pre-corrupt stage as a word document and reopened the word document in pages and reentered my references  for the session. Since the names are there adding the references just took a few minutes.  (I have only 100 references) and continued working.This way the program works flawlessly until u close it.  I tried downgrading to X2 it does not work. I think the problem is the manual references I added.  because once the file is corrupt when i try to add a citation, I get few black spaces and then the list of reference. the number of blank space is equal to the number of manual references i used from end note in that document. 

I did a trial document with references directly imported from pubmed. in that case the program work fine even with previously cited files.

Hope it helps.

For the past week I simply did not quit pages. 

In continuation with my previous post, I have found that the X2,X3 pages issues occurs only when you add references manually in Endnote. If you add references throught its online connection or by importing files, it seems to work well. 

I my article I removed all the book references and inserted online journal references that I could directly add to Endnote from Pubmed. Its working well. 

If your older files has manual references then it will get corrupted. So just open the file, do not click on any reference, export to word, reimport to pages and add the references from endnote. This time avoid all the manually added references.  

Hope this helps :smiley: . 

Apple just released an update to Pages '09 for Snow Leopard. Our testing indicates that while it does not correct documents that already have problems, we no longer could replicate the problems we were seeing before. 

Would those of you who have had this problem mind downloading this update to see if it helps new documents as well? For more information, including instructions for updating, please see our compatibility page here

Thanks again for your patience while we work with Apple to resolve this problem. 

I’ve updated Pages 09: it seems that after the update Endnote and Pages 09 work quite good!!

Please post your experiences. 

I just downloaded X3 and my footnotes on pages have wigged out.  I have a rogue footnote that everytime I post a new footnote it replaces the new one and puts the new one in its place.   It just weird.

I found a solution - I think.  I exported the documents that I was having trouble with into word documents and then opened them back up in pages and it seems to have stopped messing up my footnotes.

However, I just realized that I lost all the endnote formatting for my footnotes.

You mentioned that “this is an issue we have had other users report after they upgraded to Snow Leopard”. Were the other reports just about a Pages/X2-3 bugs, or also for Word 08/X2-3?  I have now migrated to MS Word, because I can’t afford to wait for a bug-fix, but I need to know if this option is viable. If there are also issues with Word/X2-X3, then I can continue to write, and add citations when a fix is released.

Actually, the update that Apple has released for Pages should correct the problem listed in this thread, though Pages documents that have exhibited this problem continue to have problems.  However, new documents should be just fine once you update Pages.  More information can be found on our compatibility page here:


Thus far, we have not found nor heard reports of additional issues with EndNote and Snow Leopard.  Older versions of EndNote that exhibited problems with Leopard seem to have those same problems in Snow Leopard, but X2 and X3 seem to be fine.