Endnote X3/Pages 09 bug

Hi folks,

I recently upgraded from X2 to X3, and now I am unable to insert citations into Pages 09 documents–at least into documents that already have citations in them from X2.  When I tell it to insert a citation, it lets me search for the reference I want, but then does not insert anything, or at least anything visible.  The works do not show up in the bibliography, either: in fact, I have seen no evidence that X3 produces a bibliography at all.  If I create a new document in Pages, then X3 seems to work just fine.

I am looking for a workaround.  I contacted technical support a few days ago, but have not heard anything back.  In the meantime, I am stuck with a bunch of documents that I cannot continue to work with.  I tried uninstalling X3 and going back to X2, but that does not work: whatever X3 did to the Pages plugin,  when used with X2 it causes the formatted bibliography to be infinitely long.  I’ve let it run into thousands of pages to see if it would ever stop, but it didn’t even slow down.  So now I cannot use X2 either.

By the way, this problem is exactly the same on my OS X.6 and OS X.5 machines, so it is not a Snow Leopard issue.

Any suggestions? 


I have now tried the following, with no success:

  1.  A complete fresh install of X3, after having deleted endnote-related files in the applications and library folders.

  2.  A complete fresh install of X2 and Pages 09, after having deleted related files in the applications and library folders.

I am unable to return to the working configuration I had prior to the X3 update.  It appears that X3 has really messed up my computer.

As I said before, this problem occurs, in identical form, on both Leopard and Snow Leopard.  I suspect that the problems identified in the thread on X3/Pages09/Snow Leopard thread are really X3 problems, and have nothing to do with Snow Leopard. 


I ran into the same problem. So I saved my file in its pre-corrupt stage as a word document and reopened the word document in pages and reentered my references  for the session. Since the names are there adding the references just took a few minutes.  (I have only 100 references) and continued working.This way the program works flawlessly until u close it.  I tried downgrading to X2 it does not work. I think the problem is the manual references I added.  because once the file is corrupt when i try to add a citation, I get few black spaces and then the list of reference. the number of blank space is equal to the number of manual references i used from end note in that document. 

I did a trial document with references directly imported from pubmed. in that case the program work fine even with previously cited files.

Hope it helps.

For the past week I simply did not quit pages. 

In continuation with my previous post, I have found that the X2,X3 pages issues occurs only when you add references manually in Endnote. If you add references throught its online connection or by importing files, it seems to work well. 

I my article I removed all the book references and inserted online journal references that I could directly add to Endnote from Pubmed. Its working well. 

If your older files has manual references then it will get corrupted. So just open the file, do not click on any reference, export to word, reimport to pages and add the references from endnote. This time avoid all the manually added references.  

Hope this helps :smiley: . 

1 Like