Terrible performance EN6 under Mountain Lion

Just installed EN6 for Max on Moutiain Lion 10.8.2 and the performance is HORRIBLE.  Am on a MacBook Pro with 16 GB RAM.     basiclaly EN6 is not usable.  cannot scroll through lists of ref wtih teh wheel on my mouse or with gestures … response is way too slow.   envery mouse click takes a few seconds for the software to respond.   

Very Glad i did not uninstall EN5 … it still works great on the same machine …   

This is very disappoitning … really to painful to try to teve explore new features …  is there a known fix for this?



I am having the same problem, using OS 10.8.2 on a MacBook Pro w 4 GB RAM… There is a second or two delay anytime I click or scroll within the software. It is very frustrating. I hope there is some way to fix this, as I really like being able to sync my references to Endnote Web directly from X6, but if this isn’t fixed soon I’ll just go back to X5.  

Indeed… I have to add my voice to this. Endnote 6 is barely usuable, and over longterm, unusable. I hope someone decided to actually test this product before shipping? :smiley:


Hi - Was EndNote X5 performing as expected on this same system? If so, has anythign changed in addition to the X6 installation? Is it a Mac with retina display?


 - Mathilda, the EndNote team

… I have exactly the same problem with X6.

2010 Macbook pro Intel 2.4 Ghz Core 2 Duo, 4 GB DDR3 Ram, 128 GB SSD, Os X 10.8.2

Each and every action on keyboard or touchpad is delayed for 1-2 seconds. It’s completely unusable.

X5 worked absolutely fine with the same hardware (still does because I did not uninstall this version).


I have the same problems in X4… advised to upgrade to X6 and then similar problems. Now I am told that it is the latest update from Apple that causes the issue… somehting to do with caching… just wish they would sort this out as it is most frustrating with deadlines approaching etc…

We want to confirm whether these issues are experienced within EndNote itself or Cite While You Write? It sounds like the former but I want to be sure.

Also, we haven’t seen this behavior with our testing of 10.8 and X6 so If anyone experiencing this problem is willing to work with us directly to investigate, please send me a private message. We would likely need a copy of the library and perhaps some time for you to demonstrate the issue live.


 - Mathilda, the EndNote team

… it’s not the problem as it appeared in CWYW in earlier times (which was corrected by updates). It’s in Endnote X6 itself (in my case).

The problem I am having is with Endnote X6 itself, not Cite While You Write. When I click or type to type in Endnote itself, the software is very slow to react.

I previously had X5 installed and had no problems (even with OS 10.8.2). 


For those of you who have installed Mac OS 10.8.2 and are experiencing slowness while working within EndNote, please try this test:

1.  Open your Activity Monitor.  Activity Monitor is found inside a folder called “Utilities”, which is inside your “Applications” folder. 

2.  With the Activity Monitor running, choose “All Processes” from the “Show” drop-down and then sort the display by the “Process Name” column by clicking the column’s label.

3.  After sorting this list by Process Name, look for a process called ‘appleeventsd’.  If you are able to find the appleeventsd process, highlight this entry and click “Quit Process”. 

4.  When you are prompted to confirm this action, press “Force Quit”.

5.  Once appleeventsd has been reset by the Force Quit selection, switch back to EndNote to see if you’re still experiencing slowness.

Please let me know what you find. 

Best Regards,
Jimmy M.
Customer Technical Support Representative Scientific
Thomson Reuters
Phone: +1 800 336 4474
ResearchSoft Product Support

I did not much of testing, but killing this process seems to solve the problem for now despite the fact that it pops up again in the activity log after restarting Endnote (so this will be no definitive cure i guess).

As one can see this process seems to interfere with several other applications as well (simply google it). I am not an expert in this field but it would be interesting to know more about this process.

I had the same problem, but your fix seems to work. I have a MacBook Air 1.8 Ghz, 4 Gig RAM running 10.8.2. Previously, I was thinking about switching back to Endnote X5, as the speed issue was really serious. 

Thanks — but will there be a more permanent fix soon?

From a non-Mac user, this sound like Apple’s problem, not Endnotes? 

Does not help I keep getting this message:

EndNote is not responding. Error = -1712

for both x5 and version x6

Please assist

EMAH and matlinn,

I’m glad to hear the Activity Monitor steps have temporarily cured the slowness you’ve encountered.  These steps should definitely be considered a temporary workaround until the issue is addressed by Apple.  If anyone cares to read a technical description of this underlying bug within Apple’s 10.8.2 operating system update, the following blog post outlines the issue:


Best Regards,
Jimmy M.
Customer Technical Support Representative Scientific
Thomson Reuters
Phone: +1 800 336 4474
ResearchSoft Product Support


Sorry to hear this workaround didn’t help. You may want to try calling our Technical Support department in order to see if you experience a different outcome when walking through the Activity Monitor steps with a Technical Support representative on the line with you:

EndNote Technical Support


press 4, then 1

Another possible workaround involves temporarily logging out of your user account (which you should be able to do from the Apple drop-down menu) and then logging right back in.  Of course, you would want to save any work before performing these steps. 

Best Regards,
Jimmy M.
Customer Technical Support Representative Scientific
Thomson Reuters
Phone: +1 800 336 4474
ResearchSoft Product Support

killing appleeventsd did indeed get ENX6, Word and Mac OS 10.8.2 behaving considering better. Was getting COM errors and today “error = -1712”.

appleeventsd will relaunch at some stage though, after reboot for sure and in my experiments, by quitting Word and starting at again.

Are we waiting for an EndNote update or 10.8.3?

Hello, gchallis:

As you can see in the article that JimmyM posted earlier, the underlying issue is an Apple one, so I’m afraid Apple will have to address it. Here’s that link again, in case you missed it the first time:


Or, simply Google “-1712 10.8.2” or “appleeventsd 10.8.2” to learn more about this Apple issue. There’s a lot of information out there as the problem affects more than just Word or EndNote.

By the way, another effective means of quitting that process is simply to restart or log on and off your Mac. This solution may be simpler for some users, but both accomplish the same thing.

I hope this helps.

That worked very well. Is there a plan for an update so it doesn’t need to be performed all the time?

As has been mentioned in earlier posts, this is an Apple bug so there will not be an EndNote update for this issue. We have brought this to Apple’s attention through our development channels but I recommend those experiencing this should contact Apple directly too. This can help prioritize the effort. Here’s the link - http://www.apple.com/feedback/macosx.html

  • Mathilda, the ENdNote team
1 Like