Unable to search online with Endnote x8, on Mac

"Unable to contact the online database.

Check that your internet connection is working.  Or contact the database’s vendor for availability " 

My internet connection is working perfectly fine. Just can’t search online databases on endnote. 

Any one has any solution for this? I’m really new to the EndNote

Did you select a database.  You also get that unhelpful “error message” if you try to search without having first selected one of the databases.  

do you mean this? 

Preference> Find full text… and the pic attached

No  – I meant, you need to select a database in the search module.  (see image attached) 

I also have the OpenURL box ticked in the find full text options in preferences though.  Not sure that matters.  I have this as the path, but it has been that way for ever  http://mt8fd2he2v.search.serialssolutions.com/

 I just tested with it off, and it failed to find some of the PDFs when I authenticated with my library proxy, so it might make a difference.  

Thank you for your reply, Leanne. 
I’ve attached the problem that I’m having. I’ve even added the URL to University of Sydney library. But which ever resources that I use, I am getting the same error message. 

Whenever I tried to “Find reference update”, I got the error message too. I managed to find reference update the first day when I had the Endnote on my computer. But subsequently, only error message came up

Unable to contact the online database.

Check that your internet connection is working.  

Or contact the database’s vendor for availability.

I remember (a long time ago) that our institute may have had to open the portal that Pubmed/endnote connection uses.  You might need to ask your IT people if a firewall issue is causing the problem?  

The message isn’t the same, but this KB article might have a clue?  

http://endnote.com/kb/82208 or this one http://endnote.com/kb/82209