Unwanted period if no page number in reference


I use an output style that requires the names of journal articles and book sections to be enclosed in quotations marks in footnotes - e.g., 

Mark Day and Gregory Radick, “Historiographic Evidence and Confirmation,” in A Companion to the Philosophy of History and Historiography, ed. Aviezer Tucker (Malden, MA: Wiley-Blackwell, 2011).

I have a problem when I make a reference to such an entry under the following circumstances:

  1. there are no page numbers included in the reference (i.e., the reference is to the article as a whole)

  2. another source follows the reference in the same footnote.

The problem is that endnote inserts a period where it should not. E.g.:

Day and Radick, “Historiographic Evidence and Confirmation.”; Tucker, Our Knowledge of the Past, 139.

[^ PERIOD after the word “Confirmation”; this INCORRECT]

Instead of:

Day and Radick, “Historiographic Evidence and Confirmation”; Tucker, Our Knowledge of the Past, 139.

[^ NO period after “Confirmation”; this is CORRECT]

I *only* have this problem when a title is enclosed in quotation marks. E.g., for reference types Book Section or Journal Article. (maybe others too but these are the main 2 that I use with this format).

I have tried every setting I could think of to  not display the period in such a case and I am at a loss.  The output style and a screenshot of a Word doc are attached. Any help or suggestions would be greatly appreciated!

Thanks in advance.
WTS - MG.ens (82.9 KB)

On a support chat today it was determined that Endnote is working as expected and there is no way to do what I need. This is unfortunate & I will make a feature request.

You could join the long chorus, but maybe Clarivate Analystics will increase the priority on this request?  Here is one suggestion thread on the topic.  


Thank you ^. I have come up with a workaraound that seems to accomplish what I want. 

  1. When inserting the reference, for the “Formatting” option, choose “Show Only in Bibliography.”

  2. in EITHER the “Prefix” or the “Suffix” field, type exactly what you want to appear; e.g., the reference with quotation marks & the other punctuation. E.g., Schubert, “The Final Cycle of the Speeches in Acts”;

  3. Make sure to use ALT codes for the quotes if that’s important to you; e.g., ALT+0147 and ALT+0148 for the open & close quotes, respectively

  4. Click OK to insert the reference.

This seems to work. For 2nd references to reference types using quotation marks for the title (such as journal articles), it will insert the reference just as you typed it in Prefix or Suffix without adding an unwanted period. 

I realize this is an older post, but I have the same issue. I use a modification of Chicago Footnote style, no final bib., and it anticipates page numbers after article titles (“X,” 16). If I drop the page number and refer to the title alone I get “X,”. I see no way around this except to make a final sweep by manually searching and replacing ," with a period + close-quotation mark. Is there a better way? I am not sure what Prefix/Suffix fields in your post accomplish; it sounds like a manual intervention. tx

There is another solution, equally desperate: namely, to leave out the close quote marks from the styles and then add them as I proceed, choosing whatever punctuation I need. My guess is that there is no elegant way out of this.