Why is Lib. on Congress search soooooo slooooooow? (x4 Mac)

I’m used to Bookends for the Mac, and when Is search for, say, “Cat in the Hat,” all 48 references are returned within about 5 seconds. When I use x4 and it asks if I want to return all 48 results, it takes almost two minutes to get them. In fact, I was able to navigate to the page, find the forums, and then type/submit this post in the time x$ imported all 48 references.

For Ph.D. research, this is a significant drawback, especially if I want to import, say, 10 books. No way I’m paying $100+ to spend 20 mins doing that. Is this a problem Mac side? Is it Endnote in general? Am I doing online searches incorrectly somehow?

EDIT: It’s worth noting that on occasion, I can’t even cancel an LoC search through x4 without it hanging until LoC times out.

Just some thoughts - the problem could be the program but it could also be with the connection. You don’t mention where/how you’re connecting to the Internet. What is your connection (wireless, broadband, etc.)?  If using a router to connect, did you check that the cables are secured, and did you check your connection speed? ( Speedtest is one place: http://speedtest.net/  )  Also, do you check/clean your computer to remove adware/malware which can slow down processing?

Thanks for the reply. I’m on the school network with a ~1.3Mbit connection. There’s nothing on my computer that would slow x4 down. I also noticed this with x3, though I didn’t use that enough to ever get a chance to compare. It’s certainly possible that x4 is parsing the data somehow as it downloads, but it’s definitely slow, almost to the point that I’m considering forgoing an online search for any title that’s likely to have more than 5-10 hits.

I ran a check by logging onto the Library of Congress (via wireless connection), found and downloaded the 49 cat in the hat references in a couple of seconds.

Since you’re using a network can you check with the network administrator to identify whether the problem lies with the network or your computer (i.e., connection settings). 

Yeah, I just tried from home on a slower connection (DSL here and only about 600 kbps) but a MUCH faster computer (quad core). Overall, it was faster, but still took almost a full minute to download all of them. 

Just to be sure, you’re running the Mac version? 

I’m a PC - but the issue of downloading may be affected by connectivity along with hardware related matters. EndNote tech support or your network administrator is probably your best bet at this point. You could also do a couple of more tests to provide further into to them related the following: 

  1. Does the slow downloads occur only for Library of Congress searches?  Or does the problem occur regardless of the online search database?

  2. To rule out the possibility that there’s a problem with the connection filter have you tried downloading  and using a fresh Library of Congress connection file from the Thomson Reuters site:


Contact tech support: http://www.endnote.com/support/entechform.asp

Resolving this issue is well worth the time and effort in facilitating your research work.

Looks like it might Library of Congress. PubMed downloaded 50 references in about 5 seconds. I tried an update of the .enz file for LoC but it didn’t fix the problem. It’s achingly slow.

I also meant to mention that I just completely disabled the firewall and it still didn’t help. As of right now, Library of Congress downloads records about one persecond. Other online databases do fine. Bookends (Mac only biblio software) downloads LoC records in just a few seconds (for all of them). Tried x3 and it’s noticeably faster. Looks like it’s an x4 problem I guess.

EDIT: x3 was only faster through the first 20 records or so, then it bogged down.

Very puzzling - perhaps tech support or another user on the forum has some insight. 

I find that the LoC is often slow, especially during the day. I think it is a problem with their website and the amount of traffic they get, not with the Endnote interface.

Thanks for the comment! I ran a test of Endnote x4 for Mac and for PC and definitely saw the same behavior. The download was reasonably quick up until about the 20th reference, then it slowed down to one per second. Of course, the Mac program Bookends “sees” all 49 almost immediately. Maybe Endnote is doing some processing that the Mac program isn’t, which results in the slowness.

PS As for the time of day, I was getting this even at 11pm CDT. :frowning:

The front-end proxy server at the Library of Congress is only accepting multiple requests at one time.  Our connection file was set to send a single request at a time, and this is what was slowing down the retrieval.  We have updated the connection file and it is attached here.

Please let us know if you encounter any other difficulties.

Cheryl-The EndNote Team

Library of Congress.enz (30.2 KB)

The performance is improved, but it is still sluggish. I’m getting about 1 reference per second. That’s still what I would consider “slow,” especially when compared to Bookends for Mac. Is this the best I can expect? Or are there further refinements to be made?

I have EXACTLY the same problem on two different Macs.

There’s an annoying behavior in this version of EndNote.  Once I start an online search, I can’t cancel it.  I can click the Cancel button, but the search continues.  This is a problem, because with some databases, such as Library of Congress, if it’s been more than a couple of minutes since the last search, you get timed out.  But it takes a VERY long time for ENP to realize this (2 minutes). So you start a new search and have to wait and wait until it finally comes back to tell you you’re timed out. (Error searching for records. Message from remote server: No response after two minutes. etc.)

I used to be able to start a search, tell right away that it was taking too long, cancel the search, start and cancel a second time when I received the actual error message, and start a third time in order to succeed.  It was irritating, but it worked relatively quickly.  Now the first stage won’t let me cancel.  I have to wait a LONG time, and often the Search progress window will superimpose itself on other apps if I switch to something else while I’m waiting.

There doesn’t seem to be a way to cancel and restart the connection short of quitting and reopening ENP.

The actual searches are very fast.  It’s only the timeout problem that drags.

If you let the timed out search just sit there, it will eventually recover after 2 minutes or so. That said, there seems to be a 1-in-3 chance of it happening again. I’ve gone back to Bookends, and I’ve recommended it to my department. I know Endnote losing a few thousand is no big deal, but it’s too bad they don’t seem to care enough to fix something ths simple.

Wondering about the following:

  1. Are you using the most recent Library of Congress connection file (dated May 2011)?

  2. Have you applied the EndNote X4 update to upgrade the program to EndNote X4.0.2?