x2,x3 x4, Vista x64 and Invalid Class string


I support several users who experience Invalid class string Errors with EndNote and word 2003/7 on x64 Vista. I’ve tried the process documented here:


several times on different machines with no success. I occasionally get a brief resolution if I perform a repair from the Windows Programs and Features control panel. I presume I’m somehow missing something in those instructions, but I can’t see what. Can anyone offer any suggestions, or tell me what the contents of that registry key that I’m making undeleteable should be?

Sometimes the process is triggered by upgrading to a later version of EndNote. Is it possible that there’s some CWYW related files or registry keys being left behind when uninstalling the earlier version?

Hi Xenny,

I just tried X1, X2, X3 and now X4 but i do not have successeful. All the time I have the message “Invalid Class string”.

I have Windows Vista Home Premium SP1-64-bit Operatin System, and Word 2007.

I use the UPDATE “EN1401Patch”  but do not have any solution.

Then I saw your Post. Thank you.