Attaching Files to References in X3

 I upgraded X2 to X3 (I did not deinstall X2).  When X3 came up the first time, all my references and files were present, e.g. it read my library without issue.  However, when I add a new reference, I am unable to add an attachment.  X3 doesn’t see either the directory where the file is located  or if I move the file, the file itself (even though I’m looking at the directory or file in Windows Explorer).  I have tried creating a new directory and X3 doesn’t see that either.

I had a similar problem with X2 (when trying to attach a file, the file was there but X2 couldn’t see it).  Any help will be greatly appreciated!  In advance - THANKS!


Are you on a mac or pc? 

Can you describe the directory structure you have for your endnote library and folder structure.  How long are your file names you are trying to attach? How deep is the endnote library and DATA folder?  With the directory/folder names plus the file name itself, would they be longer than the windows filename constrant of something like 256?

Have you copied or moved the .enl file without the .DATA folders? (this will cause you to lose your attachments and group settings). 

 Why were you creating a “new folder”? 

Are your Endnote Preferences, (URLs & Links) preferences set to leave the file where it was (absolute) or is the box ticked to copy them to the endnote folders? 

PC (x64 Vista Ultimate)

F:\Nova\RFF Research (not very deep)

The EndNote file directory structure is: F:\Nova\My EndNote Library.Data\PDF.  Some of the filenames are fairly long (up to 20-30 characters).  I had considered this as a possibility; however, if I go into the F:\Nova\Systems Analysis and Design\articles directory, I can see all the files there.  What has me utterly stunned is that I don’t see an entire directory that I can see with Windows Explorer or even a single file that has less than ten characters if I move the file to F:\Nova.

No, I have not copied the .enl file without the .DATA folders.  When I move the files, I use the create compressed library which moves everything over; however, I have done neither since installing X3 (this past Saturday).

I was creating a new folder (“F:\Nova\RFF2”) to see if X3 would see that directory.  It didn’t.  I tried moving the file I wanted to attach from “RFF Research” to “F:\Nova”.  That didn’t work either - X3 didn’t see either the folder or the file.

In “Preferences”, I have “Copy new file attachments to the default file attachment folder and create a relative link” checked.

I appreciate the help!


sorry - great answers, but I have more questions.

Are you trying to attach existing files to the record? 

How are you trying to “see” the folder? Are you trying to use the URL to link to these?  I am not sure there is an automated way to do that.

 I usually attach PDFs via the “drag and drop” method, which moves them to the relative folder in .DATA. So I have the folder open in one part of the desktop, and endnote in a different part of my desktop view, and use the mouse to grab the file and drag it ontop of the record in the library display, or to the record if it is already open.  In fact most of the time I just use the find full text option, to let Endnote go find it on the web and attach it (which automatically copies it to the .DATA folder structure).

The other way is to grab a file which already exists on your computer is to open the record or select the record in the library display window and use the References>File attachment> “attach file” and navigate from there. 

Silly question, but I assume that F: is a mapped drive on your machine?

Yes, I’m trying to attach existing files to the record.  For example, when I find an article regarding radio frequency fingerprinting (RFF) that is of interest, I save it to the F:\Nova\RFF Research directory.  I then create a record in X3 and part of that is attaching the .pdf file (using the “File Attachments/Attach File” within the new record) the to the record.  However, when I go to the F:\Nova directory, it does not see the “RFF Research” directory.  I know, you may be thinking, “how can it not see what is clearly there?”  That is the problem.

No, I’m not using URL’s.  When I say I don’t see the directory, I mean that when I select (from within the new record) to attach a file, X3 then opens up a file window.  I select to go to the Nova directory.  From there, it sees the other directories but not this particular directory AND if I copy a file out of that directory into the Nova directory - it doesn’t see the copied (or moved) file either.

I did try the drag and drop method (open Windows Explorer and drag a copy of the file into the appropriate reference in X3) and THAT WORKED! :slight_smile:

Yes, F: is a mapped drive on my system.

That I can drag and drop is good; however, that X3 can’t see a directory that exists on a hard drive on the system it’s installed on seems to be a software defect in the program.  If I open (for example) Adobe Reader and go to that directory to open a file, it sees the directory and when I go into that directory it sees all the .pdf files.  If I open Word 2007 and go to that directory to open a file, it sees the directory and when I go into that directory it sees the Word files.  That isn’t what happens when I attempt to attach a file using X3.

I attached two views so you can see exactly what is happening.  The Microsoft Explorer view shows the RFF Research directory.  The X3 view of the same directory does not show the RFF Research directory.

I truly appreciate your providing me with a workaround!!! :slight_smile:



Microsoft Explorer View.JPG
EndNote View.JPG