Book sections appear several times in bibliography

Hello everyone,

I am currently finalizing my thesis and am therefore trying to figure out some formatting issues.

Especially two seem to evade me:

  1. With my citations, I regularly use different the category „Book Sections“ for different chapters of a book. With my required bibliography-style each book dectioin should only appear once, omitting the author and only citing the editor. This results in me having the exact same „bibliography citation“ several time under each other, since Book Title, Editor, etc. are obviously the same. Is there a way to only show the actual book within the bibliography from which the book sections are taken?
  2. After every footnote there should be a full stop. A footnote can consist of several citations. The full stop is only supposed to appear after the last citation within each footnote. Is there a way to do that, or do I have to manually enter an full stop at the end of each footnote?

Thank you so much in advance for any help!

It would be most helpful to tell us which output style you are using, if it is out of the box, or even to attach it.

  1. How are the chapters cited in the text, so the reader knows which citation goes to which chapter? Is that included in the footnote, but not in the bibliography? It seems rather unusual, at least in my field. I would have to play around to find the best workaround. One idea is to insert the book rather than the chapters, and manually edit the in text or footnote entries. Another would be to have the template for bibliography empty for the book section but not the footnote, but not sure what that would do, as I don’t know if your bibliography is author sorted or numbered. It might create a blank entry, but they would be pretty easy to turn off cwyw autoformating at the end and delete (which you can do in the current scenario).

Then add the book somewhere, and edit the citation to show only in the bibliography.

  1. How are the footnotes separated now? In my Chicago-footnote, they separated by a semi-colon. Again, knowing your output style parameters would help immensely! But yes, it is often easiest to just add the punctuation manually. If two punctuation marks are next to each other, endnote usually removed one of them – just not sure how it decides which one!