cannot import references X7 for Mac

Running X7.5.3 on Sierra 10.12.6 (with Word for Mac 2011)

I am migrating from PC to Mac.

On PC clicking on an RIS file (downloaded or exported from web page) would painlessly import the reference to my library.

On my iMac doing the same prompts me to “choose a filter” - now the RIS file (contents shown below) is from Expanded Academic ASAP, and there is no filter for that … I’ve searched for it on on but none exists … I’ve tried choosing dozens of other filters but nothing is imported.

Even worse, using an RIS file for which a filter _ does _ exist (e.g. ScienceDirect) gives the same result - no error messages and nothing is imported.

So how do I get references into EndNote on Mac without having to manually enter every detail???

BTW I am stuck on X7.5.3 becasue the app will not update (the aparently famous “this updater was unable to find any copies of endnote that could be updated …” error which I am also trying to resolve.

RIS file contents:

AU - Denniss, Richard
DA - 2007/06//
DB - Expanded Academic ASAP
DP - Gale
JF - Journal of Australian Political Economy
KW - Pensions
KW - Retirement benefits
KW - Australia
LA - English
M1 - 59
M2 - 31
M3 - Article
PY - 2007///
SN - 01565826
SP - 31+
TI - Crisis of cash or crisis of confidence: the costs of ageing in Australia
UR -
Y2 - 2017/7/31/
ER -

The data in the .ris text file may not be importing due to a possible mis-or non-match between the “tags” in the data and the import filter.

Can you provide an .ris text file containing 5 to 10 records to permit examination and construction of an import filter? Are all the records corresponding to a single reference type (e.g., Journal article) or an assortment of reference types? If the latter, please provide of a variety of records representing the range of reference types.

Sorry, I have given up on X7.5.3 and installed X8 which is compatible with Sierra.