Endnote X8 on Mac OS 10.12.4 - cannot import RIS references from anywhere


I recently set up a new Mac with OS 10.12.4, Endnote X8 and Word 15.32. I have previously been using two other machines with OS 10.6.8, Endnote X7 and Word 14.7.2.

Apart from frequent but random crashes, I normally had success importing RIS files into Endnote X7 when downloaded from various catalogues.

However, I have not once been able to successfully import a single RIS file into X8 - even when those identical files import into X7. There is no failure message and X8 does not crash. Put simply, nothing happens.

I tried a complete removal and reinstal last night without any change in outcome.

Any advice would be gratefully accepted. As it is, I cannot progress any further.

This. omg this. I have come here to see what is going on and after toying around with endnote on osx i can not troubleshoot it out. enw, ris etc. all wont import. Well, you can select the file for import only it… just… does nothing. However, i can import using the online endnote! 

Over the last 3 months I have been importing into the Myendnote as cannot import into the app. 

Do you have Endnote X7 and X8 on the same computer? Which Endnote import filter are you using and can you attach a sample of records saved in the RIS text format to enable checking the tags in both files?

In the meantime you can import the RIS file to Endnote Online (providing the set up an account) then sync the records to your desktop.

What happens if you right click the ris file and choose to open with Endnote?

I have only X8 on the machine. I do not know which filter is being used because everything is just on default settings. All I do is select import from the menu and nothing happens. How do I ascertain which filter is being used. Attached is an example of a typical RIS file that works in X7 without any issues.

ABLITT_LivingWithDementiaRelationships.ris.zip (1.01 KB)

Right clicking to open with Endnote does nothing.

Just to clarify, when you go to the toolbar and click File >Import > File, in the “Import File” pop-up dialog box you will need to specify the file to be imported, the filter to be used, how to treat duplicates, and whether text translation is needed (see attached image).

If you are doing this procedure and the file is not importing, suggest you contact tech support in the event there might be a bug:

Technical support

For help using EndNote

Monday – Friday, 9 a.m. – 8 p.m. Eastern (GMT -5)

+1-800-336-4474, press 4

Submit a technical support request

International support contacts

Import file settings.gif

I could reproduce your issue with the .ris file you provided, on Endnote X8 on OS 10.11.6.

I looked at the file content and it seems that your RIS file violates the conventions for this format. The “TY” (type) indicator needs to be the first line of the record, and it is not.

See here: 


So I modified your RIS record accordingly, and voila, it works for import with Endnote. (attached)

Whereever you got that RIS file from, they ought to fix their format compliance. Not Endnote’s fault, after all.

Sorry for the technical answer :-}

ABLITT_LivingWithDementiaRelationships_Fixed.ris.zip (1.56 KB)

Fascinating, and thanks. Two comments though. Typically, the RIS files I download come from about a dozen different sites. I never had this trouble with X7 which was apparently more tolerant. I’m yet to find a single RIS file issuer that constructs files that X8 will open and I can’t understand why X8 suddenly so intolerant. I also wonder why the Endnote user world are not all over this if that’s the case.

Had to download the filters file from the endnote website. Can now import all the things!

I am having the exact same issue with X8 on Mac OS 10.12.4!!! I downloaded the all the filters from the EndNote website but this did not help. 

  1. Have you figured how to fix this instead of fixing each RIS file? 

  2. If not, what program do you use to open and edit the RIS file? 


Hello, I am having the exact same issue with X8 on Mac OS 10.12.4. How did you modify the RIS file (with which program did you open and edit it?)? Thanks!!

When i clicked import I found that you had to change the settings and tell it what type it is for import. RIS, ENW etc.

Hi, can you please teach me how to do this step by step? I downloaded all the filters but what do I do next? Do I just open the filter file and does it import it into endnote automatically?

Thank you. This is a real pain to figure out. 


Various Browser instructions start on page 31.  

I am using X8 on Sierra 10.12.6 and have the exact same issue. The problem does seem to be with the Filters. I have posted the fix I found worked for me here:


This worked for me, thanks!

Wow.  This solution worked beautifully!  Thanks.  I would download the .rid and the .enw file and go to import and … nothing.  As soon as I right clicked on those files and said Open with Endnote 8 (Mac) voila!