Cannot "save a copy" Windows 7 Home Premium/Pro and EndNote X2.0.4 (Bld 4459)

I have tried on 2 PCs running Windows 7 Home Premium/Pro to “save a copy” of my ENL … but nothing happens.

There is no error message. No backup copies are created …


Further to this issue: I note that on running File | Save a copy,  the folder MyEndnotesLibrary Copy.DATA is briefly created then vanishes. There are no error messages.

where are you trying to save them too?  Try just saving to a folder on the C: drive? 

Further to my comment:

Standard user settings in Vista and Windows 7 do not make it possible to make any changes within the Program Files folders of your computer. EndNote libraries saved within the Program Files/EndNote folder will be saved in a hidden location on your computer. We recommend saving all libraries in your Documents folder.

Further analysis showed the issue was due to Windows path length limitation. Endnote should show the windows error - but it doesn’t.

The cause was revealed when I tried to manually copy the endnote library and data.

Keeping the path short by saving to C:\RefCopy solved the problem.

However there is a further issue: I tried to add the endnote library and data to a compressed folder, but this was not allowed since some folder names included apostrophes.

It seems that when endnote generates the data (PDF) file folders it just uses the pdf file name, which can be very long (hence causing the above issue), without striping out characters that may be problematic for other windows apps.

Typical example of a problem file name:

C:\Documents and Settings…\MyEndNotesLibrary.Data\PDF\Leverett_Testimony-“The Geopolitics of Oil And America’s International Standing”-2706297365

I’m at a loss to understand why EndNote uses the PDF filename as  folder name - surely a unique ID based ont eh underlying record ID would have been a better choice?