File 'Save a Copy' not working - EN X4 and Windows 7

Until last week I’ve routinely backed up my library using File ‘Save a Copy’. The files have been saved to a dedicated backup folder in My Documents. Now when I try, nothing happens: the usual dialogue box appears and I press ‘save’ - but nothing is saved.

As an alternative, I tried creating a compressed library. That seemed to work until I tried opening it. When I did, I was first told that it was on a locked volume. When I tried again, the database was completely empty.

Help urgently needed, please!

Thanks in advance.

Did you check whether the library file is set to “Read-only” which may prevent it from being accessed? 

1. Locate the EndNote .enl library file on your hard drive, place your cursor on the file name then right-click to display a submenu  and select: Properties. (see image 1).

  1. In the properties dialog window, locate “Attributes” at the bottom.  The Read-only box should be unchecked (see image 2).  Uncheck the box then click OK.

If you mean the .enl file that I’m trying to ‘Save a Copy’ of, I have checked and it is not set to ‘Read-only’.


Thanks for checking. 

  1. Is the EndNote library file mistakenly located in the Program Files (x86) portion of the hard drive instead of My Documents? (If so, relocate the file.)

  2. Are you able to open other libraries? 

  3. If the EndNote “Libraries” preferences is changed so EndNote starts with “prompt to select library” are you able to open the problematic library?  (see image)

If you still are unable to open the library, you can contact tech support for assistance:

EndNote Preferences.gif

Thank you for your help.

Briefly to update, I’ve tried replicating the problem and things seem to be getting better. I have now successfully compressed and opened copies of several libraries, including my main library. I’ve also successfully managed to save a copy of a smaller library. I have deleted the compressed library from which the data seemed to have disappeared.

However, I still cannot save a copy of my main library. It has 1425 references and a number of attachments in it, but it’s not huge. Until very recently, I could and did save a copy of this library as my regular back-up. Now I can’t.

Is there any reason why this should have changed?

Answers to your questions:

  1. All my library files are located in My Documents.

  2. The problem is not with opening the library. The problem is that Save a Copy no longer seems to work on my main (largest) library. I can open all the libraries. 

  3. Changing the preference makes no difference. 

Thanks again for your  help.

Thanks for the update although sorry to hear the problem persists.  It’s starting to sound like the library file might be corrupted.  You can check this threadfor help on recovering the library and/or sending the library to tech support for assistance.

Thanks very much for your help. As a last resort I tried saving the copy with a completely different filename, and I’m happy to report that this seems to have resolved the problem.

Thank you again for your help.