Cannot save changes to out put style

For some reason I cannot save changes to the output style (using Chicago A). I save the document try to close it and it asks if I want to save the changes. I click Yes, and it does not close. I try to close it again, same thing. And on and on. I am not sure what I am doing wrong.

Are you on a network, or are your styles write protected?  Did you try to give a new name?


Version X2?   If Version X2 and your “home” directory has been changed due to your network environment, I found I had to manually create a styles folder C:\Documents and Settings\USERNAME\My Documents<span>EndNote\Styles and changed EndNote’s style folder preferences to point there.  Then it seems to pull styles from both the original endnote styles folder and the preferences folder. 

I had upgraded EndNote X1 to EndNote X1.0.1 and this problem began occurring.

A reversion to EndNote X1 seemed to solve the problem.

In case you haven’t found a solution yet…

I had this problem too, and if I remember correctly, this is the way I fixed it: Find the folder where your styles are stored - probably in Program Files/Endnote… etc in a “Styles” folder. Click properties for that folder (right-click on folder, click properties) and then uncheck “read only”, so that the folder is NOT read only. Just to be on the safe side, open the folder, select all the files, and try to un-check “read only” for all of them.

This problem started occurring again, and it’s exceptionally annoying.

I checked to see if the file folder and style files within it were not “read-only”. The folder itself was read only and the styles weren’t, so I removed the read-only status. When I went into EndNote again to alter the style, the problem persisted.

After returning to the folder C:\Program Files\EndNote X1\ I noted that the Style Folder had reverted to “Read Only”. Is this something which happens habitually within Vista?

Actually, yeah,it might be a Vista thing. I don’t use Vista regularly, but I did fix this on someone else’s Vista computer a while ago. I’m not sure, but maybe there’s a setting in Vista (within all those IMHO highly annoying security features) that prevents you from editing things that are in the /Program Files/directory. I just checked out the other computer, though, and it’s kept the read-only settings I put on it, but I’m not sure what we did to make it stick. Did you change read-only for the folder as a whole, or for the style files?  (I see you answered this)

The work-around I would suggest - unless you get a response from someone who understands Vista better -  is to go into EndNote then Edit>Preferences>Folder Locations, and change the location of your styles folder (and filters and import etc. if needed) to somewhere else on your computer, maybe within your My Documents. 

Message Edited by rstr44 on 10-03-2008 12:25 PM

At least on Endnote X2, the edited styles should be in a styles folder in My Documents and the preferences should point there.  The supplied styles stay in the Program folder.  When you look for a style, using the “Style manager”, or “choose another style”, it brings them up from both places!  This is a definite change from ENX and previous versions, where it only pulled the available styles from the preferences set folder.  I never really used X1, so I don’t know where it pulls from. If only from one, then I would copy the styles that you want, from out of the styles menu to a place under your control, as suggested by rstr44. 

If ENX1 didn’t create folders in that location, I did so manually, and pointed to them, and all worked fine. 

Message Edited by Leanne on 10-03-2008 12:15 PM


How did you get on finally? I seem to have a similar problem.

I have changed the location of my “Styles” folder to an area which is *totally* under my control,  but I seem to have the same problem : the “Styles” folder goes back to “Read-only”*wherever* I place it, but the styles are not “read-only”.

Someone please help!

may be due to some error . Is this problem solved?


Don Joao Resort

Yours was a simple solution, but it worked.  Just unclick ‘read only’ in the properties menu for the folder hosting the style files.

Thanks.  Unclicking the ‘read only’ property on the style folder worked.