"Choose import filter" message when exporting results from Scopus to EndNote X

Can anyone help?

When exporting search results from Scopus (choose results - output - export filter RIS - export - open EndNote X) a dialogue box opens up asking me to choose an import filter. The dialogue box is a new development. When I choose a filter, usually at random although I have found and used (without result) a scopus-specific filter, the dialogue box disappears but nothing else happens. My search results are not exported.

An interim solution involves using the save option rather than open when accessing EndNote here. Save the results over a pre-existing RIS file. The library opens up with the downloaded results on display, Ctrl + M merges them with the existing library. But what’s with the choose import filter dialogue box?

Any ideas?

Try emptying the cache in your web browser.


Prompt response but no joy I’m afraid. The dialogue box still pops up. Any other ideas?

We use EndNote here with a volume site license if that’s relevant information… 

I have the same problem on my home computer, but it works from work.  I have not figured it out yet.  I export and get a window that asks me to open a library, then to open or save a RIS file.  At home when I say open, it asks with which filter, so I tried to specify the “scopus” or “Refman RIS” filter and nothing happens.  At work I say open at it does it.  

both using IE6, Endnote X2

Message Edited by Leanne on 09-27-2008 10:40 AM

UPDATE:  when I use firefox from home, it works fine. 

Installation of Zotero can cause problems with direct export. Zotero has a preference that makes it the default application for handling RIS files. You have to amend this preference in Zotero if you want to use EndNote for direct export. 

Otherwise, I would check the file types in Windows Explorer (Tools>Folder Options>File Types). Does it show that RIS files will open with Web Export Helper?

And is Web Export Helper installed? In Windows XP it resides at:

C:\Program Files\Common Files\Risxtd\Risweb32.exe

I have heard of cases where Web Export Helper had to be reinstalled by repairing the EndNote installation (from Control Panel>Add or Remove Programs).



Thanks John, Zotero is not installed on that computer, and filetypes for RIS does have the webexporter helper associated and the Risweb32.exe is where you described.  Is there some reason it would work with firefox but not IE6?

From another thread. I haven’t tried it though. (being at work).


“On Windows if you are asked to choose which program to use to open the file you would need to browse to: C:\Program Files\Common Files\Risxtd\Risweb32.exe.” 

Peter Travis
Customer Technical Support Representative
Global Customer Support

hi there

i had the same problem, too. importing references from all journals faced this problem. but, i solved it so easily.

at the fiirst, let see was the cause of this error. i saved my library file in the same folder of the software in the windows drive directory, therefore, any changes couldn’t be saved. new references or styles could be countered as the new changes for the ENDNOTE program that couldn’t be saved in the library.

i couldn’t find any solution for this annoying error. but i find the solution in changing of the library directory. in other words, i saved a copy of the library file in another drive than “c:” and this is it. this is the solution. the “choose import flter” error didn’t appear again.

i wish you can solve this problem, too.