Convert et al to italic for in-text citation in Endnote

Hi All,

I’m sorry for posting the same problem, which has been solved for some users

I applied the solution mentioned in the above posts but does not work for me (see screenshot)

I edited Harvard style to convert etal to italic in the edit output style window, and used the same style in Word and Endnote, then clicked update citations and bibliography, but does not work also

I have been so tired of trying many times without desired results

So I developed a macro code to convert to etal to italic, but the problem when update citations and bibliography, it will restore the original format.

So any additional guidance please to fix this problem with special thanks.

Try the output style in the attached zipped file.  Open the zip file, open the file (which should open in endnote) Save As the file from the Endnote program (which should save to the folder designated in your preferences and endnote will be able to find it.  DO NOT SAVE  IT TO the name Harvard as Endnote will have two copies of that and invariable use the wrong one and not the new one.  

then in word, make sure it is the saved file (which is either “Harvard italics et al” or perhaps “Harvard italics et al COPY” (but you could remove that COPY part before you save it) in word (it doesn’t matter at all what is selected in the Endnote program).  You may need to “select another style” if it isn’t already listed  in the drop down.  

does it work?  
Harvard italics et (2.64 KB)

Thank you so much, my bro

It works perfectly

So what is the problem? Is this a new style version of Endnote 20 because I am using Endnote X9?

Thank you again

Best Regards

You can try zipping yours and attaching and I can look at it.  The version I attached, I edited in X9.3.  

Thank you again

My bro, I have been shocked for two days when I was added some additional refs, and when I update the citation and bibliography, it was restored to the original format (Regular et al).

I deleted your custom style and inserted it again from scratch, the problem persists. Consequently, I tried to edit my own original Harvard style, also the problem persists.

Finally, I disabled the “Link in-text citation to refs” feature (My favorite feature) and updated citation and bibliography, the problem was solved. The attachment file contains screenshots and my current own Harvard style.

My question is why your custom Harvard style worked on that day even when the “Link in-text citation to refs” feature was enabled, why then doesn’t work. Additionally, is “Link in-text citation to refs” feature behind this problem?

Thank you

Harvard_Itlalic & (165 KB)

No idea. I think you should call tech support.  I assume you are always working on the same computer?  If not, then the edited output style wouldn’t be available on the another computer, even though it might still appear selected in the word document.  I agree the “link” shouldn’t matter… Switch to a different style and then back to your preferred one.  

What kind of computer and what operating system are you working on? I am on windows.  

No changes occur, and I’m using the same computer

I’m on Windows 10 and Office 2019.