Critical Bug in CWYW for Word 2008 (Mac)

Hi! :smiley:

After installing the new fix to enable CWYW for Word 2008  (Mac) I have come across the following bug:

The tool bar for CWYW appears when I open Word 2008. HOWEVER, all the icons in Word itself are greyed out. Meaning I cannot click any of the Word icons such as “Save”, “Print” and so on.

Note that I had already installed the Office SP1 as well as the patch that was released by Microsoft on June 25th.

Since I need to have Word 2008 functioning, I uninstalled EndnoteX1. However, this did not resolve the problem. The CWYW tool bar did not appear, but the icons in Word 2008 itself still remained greyed out.

I finally discovered that by removing the Endnote file in the Word startup folder that Word would work properly again.

This is a critical bug that needs to be attended to. Until the bug is fixed, I am unable to use EndnoteX1. (And how about bad timing. I am in the midst of writing a paper with a deadline for July 1.)

I am glad some progress has been made on CWYW for Word 2008. It must have been a real hard job for the programmers as Microsoft changed how Word worked for Word 2008. Just a little more work and I am sure we will be forever grateful! :smileyvery-happy:

Looking forward to any news.




Although I posted for help on this forum, I eventually received a reply directly from support. The bug, however, still occurs.

Since there are many viewing this post, could someone let me know if they are having the same problems? It woluld really help! 

Following is the reponse I received and my recent request for further help …

We have confirmed the EndNote X1 Cite While You Write (CWYW) tools do work for Word 2008 with the 12.1.1 patch installed. I would suggest manually installing the tools by following all the steps found here:

Let us know if you need any further assistance

The instructions to that the link leads to are:

Macintosh EndNote X1 & Word 2008

Q: How can I get the Mac EndNote X1 CWYW commands to appear in Microsoft Word 2008 under the Tools menu?
A: Get the update here.

If after installing the Word 2008 SP1 update and the EndNote X1 CWYW 2008 update the tools still do not appear:

Close Word and EndNote.
Open your hard drive and go to Applications:EndNote X1:Cite While You Write.
Copy the files “EndNote CWYW” and “EndNote Web CWYW” by highlighting them and going to “Edit > Copy.”
Go to the folder Users:[your login name with the house icon]:Library:Application Support:EndNote and paste the two files, “Edit > Paste.”
Go back to the folder Applications:EndNote X1:Cite While You Write.
Copy the file “EndNote CWYW Word 2008.bundle” by highlighting the file and going to “Edit > Copy.”
Go to the folder Applications:Microsoft Office 2008:Office:Startup:Word and paste the file, “Edit Paste.”
Start Word, go to “Word > Preferences” and click on “File Locations.”
If the Startup folder is not set, highlight “Startup” and click on “Modify”. Select the folder Applications:Microsoft Office 2008:Office:Startup:Word and click “Choose.”
Click “OK” and close Word.
Start EndNote and then start Word.

However, the bug still occurs. So following is the message I sent to support seeking further assistance.

Hello again,

Unfortunately the bug still exists.

When I open Word 2008, the Endnote X1 CWYW toolbar appears. HOWEVER, all the other tool icons for Word 2008 are greyed out meaning I cannot click on icons such as the icon for “print”, “save”, “undo” and so on.

It appears your instructions are for people who do have the tool bar for CWYW appearing. It appears for me, but when it appears I cannot not use the main Word 2008 icons.

One thing I notice is that if I reduce the Word 2008 window into the dock then click again to have it appear, the Word 2008 icons can be clicked. But, as you would understand, I should not be forced to do this each time I open Word 2008.

Looking forward to your assistance.


I hope this problem gets solved because I don’t want to waste my money on a new version of endnote due for release this summer (2008) if I am going to get a repeat of the same problem. Come on Thompson … looking forward to your support!



Hello again,

It seems that the bug I have been reporting is known by Thomson Reuters support. Following is the response I received directly from support. Hoping there is a fix soon. If you have the same problem and post, maybe it will become the top item on the support list to fix.



There does appear to be a minor glitch here that has been reported. If you simply open a record and EndNote and close it and then return to Word, the icons and commands should all be functioning. If more information regarding this glitch becomes available, we will post it on our EndNote Web site.


Despite official acknowledgement of this glitch, there has been no further follow up from Support. I still have a non-working Endnote. Am reverting back to Endbooks, which is way cheaper and more reliable. The only reason I wanted to use Endnotes is that it is site licensed at my university. I am considering putting in a complaint to the university computer center. Endnote was not cheap for me to buy and so was expecting at least a little better support. If you read this as me being annoyed, you read correctly.


I purchased X1 to update X for max.  To date, it has rejected the serial number of the udate.  I’ve called support and waited hours.  Nor have I been successful in uninstalling X1 – I simply haven’t been able to solve the problem.   I cannot believe the bugs affecting Mac users.  The Mac notebook is the number one selling notebook in the country.  And Apple is selling more computers over $1000 than any other company.

Personally, I believe the problem might be Word.  It’s a micrsoft product and perhaps what Mac users need is EndNote written for a Mac based word processing document.  One way or the other, it’s been a waste of time and money.  If anyone has any recommendations, I would appreciate hearing them.

My solution for the interim is to use ForrmatEase which formats text and creates fast, accurate citations and references in APA style.  It doesn’t search the internet but gets the job done.

Hi ordazza, I have exactly the same problem you do with word 2008 for Mac, installed with Leopard operating system. The only fix I’ve found so far is to minimize the document (it shrinks down to the dock) and then expand it. The menus then seem to operate normally.  It is an annoying thing to have to do with almost every single word document I open. I’m not sure if it is due to endnote or due to word itself.

Ozdazza,  I called endnote and received help on the phone with the installation of Word with OS X Leopard.  I ended up installing the current endnote version with Word 2004.  The tech advised me there was a patch needed for use with Word 2008 and that I might be happier with the 2004 version.  There were a number of workarounds required with the installation that we completed, and the online help vastly sped things up.

You might want to call endnote and obtain direct help.  If you receive a final solution regarding usage with Word 2008, please post to let us know what needs to be done.  I suspect that they are working to fix this bug and that it could happen at any time.  Until that officially occurs, then a tech might provide helpful support.

Hello Ed & Lisad

It is good to know that I am not the only one battling with this problem. Since I am in Japan, I would have to stay up overnight in order to speak with Support. Instead, I had been going back and forth with Support via email. (No use asking Support in Japan, I learnt I knew more about the issue than their own specialized staff who in the end contact Thomson Reuters to get form replies).

Basically, it took a while, but finally I had Support get their “Product Management Group” to post on the Endnote website that the bug formally exists.

Thus now on you will see written:

Some users have reported that all the tools and menus in Word 2008 appear greyed out after installing the EndNote X1 CWYW patch for Word 2008. Switching the focus away from Word 2008, to the Finder or another program, and then returning to Word allows the toolbars to work.

Now that they formally admitted there was a bug, I asked Support to fix it pretty please. The response I got was:

… I highly recommend that you submit this as a request through our suggestions form:

This goes directly to our Product Management Group and is the best way to make your voice heard when it comes to anything you may want to see included or changed in the software.

Since Support are on the ‘inside’ and know about this bug inside and out, I asked if they could put in the request. The response I got was:

In order to see results, it would help if you as a consumer of our product were to contact our Product Management Group directly through the online form I indicated. 

I shook my head in disbelief. I have to put in a request for a new feature for a bug? That one is beyond me. Plus I felt like I was now dealing with one big government bureaucracy. Support not being able to make a request to their own Product Management Group to fix a bug is puzzling to say the least. Thomson Reuters seem to want us, the customer, to put in requests for new features that are actually bug fixes and not their very own Support team who know about the problem inside and out! Why do *I* have to go running around on the Thomson Reuters bureaucracy wheel?

So, basically I have given up on Endnote. I bought an excellent application made by a Mac programmer called “Bookends”. It deals with the Word 2008 issue wonderfully using an apple script. There is another application designed also specifically for the Mac called Sente. It looks wonderful and seems to work for most people, but it did not work the way I wanted. I would give both a try.

If you guys would like to actually put in a request to the Product Development Team, I will chime in as well to add to the voices. My university has a site license for Endnote. But I am going to strongly insist they provide us with other real Mac alternatives like Bookends. Bookends is way much cheaper and they are not insisting that you fork out heaps of money for a minor upgrade like Endnotes does.

Let me know what you plan to do and we’ll take it from there.

Cheers! :slight_smile:



Hello again Ed & Lisad

I have just registered my request to have the bug fixed at:

It would really help if you could put in a request too so that it is made a priority.

Looking forward to your help.

Cheers! :slight_smile:



Hi ozdazza, will do!! it’s still happening to me, such an odd bug… 

Thanks for the recommendations, people. I used that form to complain about Endnote for Mac bugs in general experienced since release 7. I guess I’m just slow. Or rather, I allowed myself to become ‘dependent’ on Endnote.

It’s very easy for Endnote staff to point fingers at Word and say it’s Microsoft’s fault that Word consumes 100% CPU when Endnote tries to do its job, or that it’s Microsoft’s fault that Word crashes when Endnote reformats the bibliography or can’t link up a reference. 

No, man. It’s not Word’s fault. Endnote is not compatible with Word. It’s very plain.

Endnote is also incompatible with itself - it crashes itself when ‘recovering’ my enl database! 

I have unformatted citations, discontinued using Endnote and have been editing a large docx in Word 2008 for several weeks WITHOUT ONE PROBLEM. 

I still get that annoyed greyed out toolbar, but that’s easy to avoid. Word no longer consumes 100% CPU or crashes. Not even once since discontinuing integration with Endnote. But I don’t have my references either!

Any suggestions other than purchasing other software? My plan now is to somehow regenerate the bibliography with Endnote, print the bibliography to PDF, copy and paste to Textedit, then copy and paste to Word and reformat the entries and citations with APA to do it the old fashioned way. Crazy but it’s true.



Hello Bill

I am thankful for having endnote available for the Mac, but have been continually disappointed with its execution. It has been a while since I visited the endnote website, and I see now that X2 is available for the Mac. I have no idea if all the problems have been fixed with this new release and without any confirmation I have no plans to plunk any more money.

Bill, you mention that you get the grayed out toolbars in Word 2008. Is this with endnote installed or uninstalled? This was so much of an annoyance that I uninstalled endnotes, including the installed .dot file in the Word startup folder, and all was okay again.

I know you are not after suggestions for other software, but after going through hell with endnote, the application “bookends” has been a heaven send! :)  My university has a very particular Harvard format to follow for writing up the PhD thesis. Essentially they have tailored the format so that non-English texts (i.e. mainly Asian) can be cited. So I have had to change the Havard format in the software which was a breeze in Bookends. I am not sure, but I believe it can also import endnote databases. A quick check on their website should let you know if this is possible. Although it means purchasing other software, it might be well worth it for you in the end.

All the best in your research … that is what endnote should be really supporting us in, not having to worry about the technical stuff so we can concentrate on our research … but it has almost been the other way around!!!

Cheers! :slight_smile:



Hi Darren (and all). I did not uninstall Endnote X1 yet, so it is still causing the greyed out menu problems in Word 2008. But you just have to _do_ something in Word, e.g. Save the file or follow what other people did (see above) and the menu ungreys itself.

I have made another post elsewhere to learn how to properly uninstall Endnote so I can try to reinstall it. I see that X1 did not remove X when X1 installed. I want to remove them both cleanly, and try to install X1 then the CWYW patch and try again. I must submit my thesis in two weeks! Thus, I do not want to change software tools now at the last minute. I must endure the pain that is Endnote!

I have experienced so many problems with Endnote since release 7, 8, 9, X and now X1. There is no way I will purchase X2. Word X, 2004, 2008. It also doesn’t matter. Endnote still frequently causes Word to consume 100% CPU, or causes Word to crash, crashes itself, and causes the Word menu to grey!

I am not convinced Endnote is worth purchasing, upgrading or using anymore. It is driving its users away. And that’s a shame because it promised so much yet has delivered more frustration than anything else. I kept using it to save me time but like you. Unfortunately, the opposite has occurred and after 5 years or so, Thomson/ISI/Endnote still does not seem able to fix these problems.

After I submit my thesis, goodbye Endnote & Word, hello OpenOffice or LaTeX or bookends  - - whatever! Just something that works, please!


I finally uninstalled Endnote. Word’s buttons are no longer greyed out. Word no longer endlessly spins wasting CPU when I ask Endnote to do something. My document no longer expands to 500 pages because Endnote reformats the bibliography to some strange style. Now I will only deal with Word’s deficiencies and not those caused by Endnote’s poor integration with Word. Here’s how I did it.

Follow Endnote’s technical support suggestions, with the noted caveat:

You may need to clean up the field codes in your document.  Try the following steps:

1.  Make a backup of your document.

 2.  Choose the “Tools > EndNote > Unformat Citations” command, which will remove the reference list and revert the citations.

 3.  Do a [Apple]+A on the keyboard to highlight everything.

NB: the next step removes many Word cross references especially wrt lists of figures and tables

4.  Do a [Apple]+6 (above the “T” and “Y” key) to remove any additional hidden field codes.

 5.  Do a [Apple]+C to copy the highlighted text.

 6.  Open a new document and do a [Apple]+V to paste.

 You should now be able to format this cleaned up version of the document without running into problems. 

I added the NB (in South Africa this is some Latin abbreviation for WATCH OUT!!!). Once you Apple-6, you lose a lot of things that Word put in to help manage automatic numbering and cross-referencing, especially wrt figures and tables. I think this is because Endnote also mucks with Figures and tables whether you want it to or not.

I am now working with a docx after using Endnote to unformat its own citations. However, I did manage to save an Endnote-formatted bibliography first, as follows:

NB: _before_ unformat citiations

  1. generate your bibliography with Endnote as usual (providing you still can and still have some patience left)

  2. close Endnote, hide its toolbar within Word 2008, then close Word

  3. reopen the docx in Word. Then highlight and copy (apple-C) the bibliography, create a new Word document, and paste (apple-V) there

  4. Make sure the pasted bibliography is normal text, and not Endnote-formatted. If you can’t figure out how to do this, then rather paste into Textedit or some other non-Word editor so you get just the text and not Endnote’s underlying format tags. Save it.

  5. In Word, Tools->Endnote->Unformat citations

  6. copy and paste the Endnote-free bibliography from that newly created file back into the original document where _you_ want it! :slight_smile:

  7. Uninstall Endnote (close any open library, then use the Customizer.

  8. Copy any modified ens or other customised files before you trash the Applications->Endnote X1 folder (you never know - some other utlitity like Bookends might import them!)

  9. If you start up Word again, you’ll notice the Endnote menu is still in Tools! That uninstall process is deficient! Simply go to ~/Applications/Microsoft Office 2008/Office/Startup/Word and remove the Endnote bundle.

You’re finally free of Endnote! You just have to edit your citations and references by hand. Bummer. But that’s what APA was designed for in the first place. 

However, I still see the Endnote toolbar inside Word even though I completely uninstalled and deleted Endnote! Someone please help me get Endnote out of Word completely! Otherwise, I’m just gonna uninstall Word and reinstall it. 


Now that EndNote X2 is out, I was wondering if the new version has fixed all the problems have been reporting for EndNote X1 with Word 2008 for Mac?

Could someone let me know either way? Especially some word  from Thomson Reuters would help.

Darren McDonald


Hello again folks! :slight_smile:

To get a quicker response to my question above, I contacted support. My question and the response from support is as follows:



I had been using EndnoteX1 with Word 2008 for Mac but found a critical bug which grayed out the toolbar icons in Word. The only way that this could be resolved was by clicking on a different window and going back to Word. However, this was such a bother that I ended up uninstalling Endnote and so stopped using it.

However, now that Endnote X2 is out I was wondering if the bug was fixed. I did notice in one of Microsoft Office 2008 for Mac recent updates there was some sort of fix included that mentioned Endnote.


Hello Darren,

The Word 2008 12.1.4 update should resolve the issue for both EndNote X1 and EndNote X2.

So, it looks like the issue has been fixed. It is good to see that Microsoft has been so cooperative to provide the update/fix to solve the issues. I have been in contact with Microsoft Japan previously about bugs that were happening with Word 2008 in Japanese and they were quick to make the update. It is rather ironic that Apple is dragging its feet to make Pages compatible with Endnote and other 3rd party software. So unlike Apple …

Cheers! :slight_smile:


I think Thomson needs to make another board “Endnote problems with Mac”, and consider more seriously about the Mac-related problems.

I used to be a Mac user, switched from MS-DOS/Win 3.1, just because I wanted to use Endnote Plus. I used Mac until Endnote version 7. With the introduction of Endnote 8 and shift to Win-first policy, I also switched myself back to Windows PC. It’s kind a shame to see so many complaints from Mac users. Mac users are generally WYGWYS oriented, and spend less time on tweaking things.

I think Thomson is losing lots of Endnote users from Mac OS side, because of poor implementation and lack of serious attention. I recently started to recommend Zotero for Mac users around. Endnote is not the only reference managing software anymore, and it needs edges that outperform others, and stability, of course.

Message Edited by myoshigi on 11-26-2008 10:04 PM