Direct export error message on Vista with X2 need help

Hi all

I have been successfully exporting from a range of databases until a few days ago and now I cannot get any of them to work. I fear some or other update has done the deed. The message is:

"C:\Users\Janice\AppData\Local\Temp\delivery-2.RIS could not be opened, because the associated helper application does not exist. Change the association in your preferences. "

Can anyone interpret this msg for me - I would be grateful.

Janice Knopke

I haven’t done this in Vista, but this page seems to explain the process.

You need to find the extension .ris and associate it with Web Export Helper, which is a utility installed along with EndNote. You should also find .ovd (for Ovid direct export) and .ciw (for Web of Knowledge direct export) and associate them with Web Export Helper.

Finally, check .enw and make sure that it is associated with EndNote.

Thanks John for that advice - took me a while, but I eventually found the Set Associations (I did need to know that), and it appears that all of the file extensions you mentioned are correctly associated, so it is back to square one. I might email tech support.


Hi janice,

I have exactly the same issue, and my settings too were already correct in the ‘Set Associations’ box.  Did you find success?  What did you need to do?


Hi Tara,

Not sure if you’ve solved your problem. But I’ve just had the same issue when exporting in Firefox (Internet Explorer still worked) having upgraded to X3 this morning. I’m using Windows XP, EndNote X3, and Firefox 3.0.11

I checked the settings as per John’s comments, but given that I can’t change the settings without Service Desk help (they’re locked down) I thought I’d investigate further. I did find two listings for RIS Formatted files in Firefox / Tools / Options / Applications  and having changed those to EndNote all is working again. 


Message Edited by Kirsty on 02-18-2010 12:31 PM

Message Edited by Kirsty on 02-18-2010 12:31 PM