can import .ris files from web

After upgrading to X4, I can’t import .ris files.  I get the following error message:

C:\Users\Robert\AppData\Local\Temp\00000001-8.RIS could not be opened, because the associated helper application does not exist. Change the association in your preferences.

When I check the association, I find it is set to ResearchSoft Direct Export Helper, which I think is in fact correct.

Tried clearing cookies and the cache, but get the same problem.

How correct this?  It’s been reported to technical services, but no response yet.

bob wears

Is it impossible to import RIS files at all, or does importing the RIS file by choosing File > Import and setting the import options to RIS work? 

If it’s only the automatic download and import that’s failing because the PC isn’t recognising the file associations properly then File > Import is a workaround until the problem with automatic imports is solved.

You might be able to set EndNote as the helper application for RIS files in your browser’s preferences.