Edit citations in footnotes

I am using footnotes in the style Harvard Intl J Press. When I want to add a citated page number I use the “Edit citation” function and add the page number as a suffix since I want it to look like this “, p. 5”. The problem is that in the footnote the change is visible when the citations are unformatted but it does not show when I format the citations. It’s the same case if I use the “prefixe” or “pages” options. Is there a solution to this?

Did you modify your style such that “Cited Page” appropriately comes up at the place you want?

“Edit citation” command does not automatically add cited page. Style needs to be modified if it doesn’t have “Cited page” in citation template, for example.

I haven’t looked at the Instructions for Authors for this journal, but the EndNote style is set up as an author-date style, like Harvard or APA. This means that it normally requires references in the text of the document, in the form (Smith 1999).

So presumably citations in the footnotes should also follow that format? If you open the style for editing and go to the Footnotes>Templates, you can use the “Format citations” box to select “Same as citations.” Then your references in the footnotes will be in the form (Smith 1999) and you can use the Edit Citations command to insert page numbers as a suffix.

As myoshigi suggested, you can then edit the Citations>Templates to insert the Cited Pages field, which will allow you to use the Pages box in the Edit Citations dialogue. But this is a bit trickier and involves use of EndNote’s special formatting characters.

Thank you so much for your answers that helped me to partially solve the problem, esp. for page numbers.

However, if I switch to a style that requires footnotes, eg. Philosophy of Social Sciences, I cannot get either suffix or prefix to show in the formatted footnote although it’s there in the unformatted footnote. I can make it work if I choose “Same as citations” in Footnotes - Templates but then I overrule other functions with footnotes, e.g. full reference the first time mentioned and then short forms. Any clue on what I am missing to adjust so I can use suffix and prefix with footnote styles?

If you are using a footnote style where the Footnote Templates have the setting “Format citations in – Using Footnote Format”, then the Prefix and Suffix functions won’t work.

Footnote styles in EndNote have always been like this. If you need a prefix, you just type it in the footnote before inserting the citation. For a suffix, you use the Pages box in the Edit Citations dialog.

Normally, all real footnote styles (like Philosophy of the Social Sciences) have their templates configured to support the Cited Pages function.

Thank you very much! Such a simple yet difficult-to-figure-out solution. And how typical that I got stuck and did not just try to put in a suffix manually :slight_smile:

Very grateful!