EndNote 21 crashing during Find Duplicates search

I recently upgraded to EdnNote 21, and I have noticed that sometimes when I try to find duplicates, the software suddenly shuts down without any error messages. Fortunately, I still have EndNote 20 installed, and that still works the same. Has anyone else seen this?

Same here, but not sometimes, rather nearly every time !

To specify:
tasked with merging databases from various project teams into one, I need to use the “Find Duplicates” feature all the time. Worked great with X9.2, but now with 21.2, when trying to find duplicates within “Groups”, Endnote invariably crashes (this function in the menu now listed under “Library” - but even when using “All References”, Endnote crashes when saving after having edited within the doubles popup window, regardless of whether the database holds 200 references or 10.000.

EndNote databases are stored locally of course, and system is 64 Bit Windows 10 Enterprise 22H2 on a Fujistu PC with CPU i5-8400@2.8GHz, 8 GB RAM.

1 Like

(Well, at least we’re not alone!)

But why just us two?

This is reproducible, I tried it on a library copied with the restore function here in the office, and I tried it on my home PC with twice the RAM and my own copy of EndNote 21 - just took a few references more before crashing without notice.

Guess I’ll have to revert to EndNote X9.2, work with that as before, and then merely transform the resulting databases into EndNote 21 format for use in the office … (and no, we don’t and will not use any cloud not hosted on our own servers)

It seems to be something with version 21.2. I have Endnote 20 still installed on the same computer, and it doesn’t have this problem.

Happens to other users in our department also – so I just sent a complaint to Support, including this link.

Answer: "… Upon checking further with our development team, they have confirmed this is a known issue in the EndNote 21 program that affected Windows users and they are working on it. As of now, there is no timeframe released yet on when this issue will be fixed as the team is still in the process of investigating it further. We apologize for the inconvenience caused in this regard and appreciate your understanding. For further news and updates about the EndNote program, please refer to the link here:
Available updates - EndNote

Thanks for your persistence. I’m hoping they come up with a patch soon.