Endnote 21 - import pdf does not work

Hi, I have just bought an Endnote 21 license and am finding so many bugs compared with Endnote X8 which seemed to work so much better. For example, in X8 you could drag and drop a pdf into the library and it would automatically create a new reference and upload all the reference information for you.

Not only does this not work with Endnote 21, but the ‘import file’ function does not work either when I select a pdf to import.

Are there any solutions to this?


Dear Gill,
please give me the following infos concerning your pdf message:

  • Are you using WIN 11 or Mac or Linux?
  • please send a picture of the EN 21 window concerning the drag and drop bug.
    I am using EN 21 with WIN 11 Pro and Linux with Solus 4.3 as O.S. and wine 8.9 (with Wine 32 dlls
    and winetricks).
  • Are you using PDF files without DOI or scanned?
    I am testing EN21 for a review.
    The import function of pdf files and pdf folder occurs problemless with WIN 11 Pro or Linux
    Solus 4.3).
    I send you pictures with separate mailing
    Thank you in advance for your answer.

If it is any help, I have Endnote V21 (upgraded from V20 and V17 before that) on Windows 10 upgraded to Win 11 and I have no problem with importing PDF’s

Also, if it was a general problem, I think the forum would have been alight with it.

Hi trensofty,
Thanks for your message.
I’m using Windows 10. There’s a screenshot below of the import file window I’m trying to use.

I typically import pdfs directly from the journal website which include the doi and reference information.

When I use the import file window, the process completes, but the file is not added to my library. For example, the number of ‘All references’ stays the same, ‘Recently added’ remains empty, and when I search for the file by first author name it is not there.

Previously, I could select a reference from my entire library in one pane and see a summary of the selected reference in a side pane. Then I could drag and drop a new pdf into the side pane, and it would be added as a totally new reference, complete with all the reference information (authors, date, title, journal, page numbers, doi, etc), including the pdf. This used to work also with scanned pdfs, except a new reference would be created with only the name of the file that you saved the pdf with in the title row, and the associated pdf.

With the new layout, you can also select a reference and see the summary of it in the side pane, however if you drag and drop a new pdf into the side pane, it is added to the selected reference, rather than creating a new reference.

I can import citations perfectly, and attach pdfs to those no problem. It is only the quick method described above that does not seem to work.

Thanks for any help

A stab in the dark… Have you tried downloading the file to a local drive and importing it from there? That is how I do mine. I am not sure if I have ever done one directly from the internet. Otherwise, you might have to ping Endnote support.

Hi JAmedia,
sorry I should have made that clearer. When I download a pdf from the journal’s website, I save it in a local folder then attach it from there to a reference (usually a citation that I’ve downloaded for the article and imported directly into my library from the journal website.

Hi Gill
Then I am at a loss. Hopefully TRENSOFTY and or someone from Endnote will reply.
All I can say is if it was a major problem in Endnote, the forum would be alight with it.

Al I can think of now is check the preferences. There might be something in that?

Thanks Chris,
I checked my preferences but can’t see anything that would affect this. It’s a small thing, but a bit annoying. Maybe no one else was using this useful function?

Hi Gill,

From the “Import File” window you’ve shared, the import option currently selects “EndNote Library”. Try changing the import option to “PDF”, and see if that helps to import the PDF as a new reference.

Sometimes, the name and location of the PDF also affect EndNote’s ability to import that file. See: EndNote: “Could not add link” error message when linking to a PDF file (clarivate.com)
Try renaming the PDF file to something shorter and ensure it is locally saved.

I tested the PDF drag and drop feature as you’ve mentioned, and found out that dragging the PDF file to the “All References” tab on the left menu panel does the trick.

Hope these helps :slight_smile:

1 Like

Hi faaiz,
Many thanks! You are wonderful. Both of these options worked for me too. Brilliant to know these shortcuts are still available.
All the best,

1 Like