EndNote adding period to URL hyperlink in Chicago 17 template

Hello –

EndNote is adding the period at the end of the URL inside the hyperlink for Chicago 17 footnotes. This breaks the hyperlink, causing 404 (file not found) errors.

How can I format my URLs to get around this?


In EndnoteX9.3.3, I get the bibliography entry to correctly format as a link, but in the footnote, I don’t get it to hyperlink at all. I see a | (separation character) after the URL before the period in both templates.

Hi Leanne –

I too use 9.3.3. I paste the URL in from the browser. It pastes in as a live (blue) link. In the URL field no period. In the footnote there is one, appended to the blue URL and thus breaking it.

I’ve never seen the | in my dealings.


There should be numerous separation characters in the templates as above

Hi Leanne –

Ah Hah! I was talking about the example provided, which for me is a footnote. Here is an actual situation:

Rachman, S. , and T. McMillan. "Psychological Analyses of Courageous Performance in Military Personnel."Final Report Jul 1983–Jun 1986, Institute of Psychiatry, London (United Kingdom), 1986. https://apps.dtic.mil/sti/citations/ADA176275. Defense Technical Information Center (ADA176275).

It has two problems (and maybe more) that I want to fix. The first is the ending period inside the URL. It needs to go after it. If you click on it, it goes astray. If you edit the period out in your browser, it works.

The second is the Personnel."Final construction. There needs to be a space before Final.

I have never edited a template. Are there solutions there?

Thanks, Mick

hmmm, I hate footnotes.

Which ref type is this? Can you attach your output style?

I do know that the bibliography setting (if you need a bibliography) should be changed so that only the DOI is listed in the template and the substitution field option can be set to use the URL if there is no DOI. – otherwise I get a DOI and a URL – not sure if that is true for the footnotes which appear to only have a URL and no DOI.

For the space, you need to put a link adjacent space in front of the field name that contains the “Final Construction” title in the record. (I know you don’t want that in quotes, just to specify the text). (it looks like the circle in the above).

But in my style/endnote/word combination, I can’t get a footnote url inserted by endnote, to be a hyperlink! I wonder if a setting in my version of word is preventing it. Yes I can paste one after the endnote inserted footnote, but if I convert the endnote inserted footnote, it resets it to not hyperlinked when the document updates.

So if it is converting to a url link in the footnote for you, I would just remove the period after the url field in the template (then it can’t be usurped) and just put a period at the end after you insert the endnote field? less painful.

Hi Leanne –

The output is vanilla Chicago 17. Most of my references are theses. Here is the Chicago 17 Thesis footnote:

Author, “Title”| (|Degree Thesis Type, University, Year|)|, Cited Pages|, URL|, Database Provider| (Document Number)|.

There is nothing adding the period after the URL that I see so I’m still searching, not knowing what to remove. :confused:

I get the URL by visiting the database provider, copying the URL from the browser, and pasting it into the reference’s URL field. After updating, in the lower right of my library window is a blue hyperlink waiting to be clicked.

yes, if there is no Database provider or (Document Number) then the last period following the “separation character” (the vertical line) is added to the URL. Take that away! –

Chicago 17th Footnote Nov-2018.ens (148.0 KB)
Try this one, where I removed the period at the end of any footnote template that ended with a URL.

Hi Leanne –

Thanks, but didn’t make a difference. Looking again at my example of 10/24:

Rachman, S. , and T. McMillan. "Psychological Analyses of Courageous Performance in Military Personnel."Final Report Jul 1983–Jun 1986, Institute of Psychiatry, London (United Kingdom), 1986. https://apps.dtic.mil/sti/citations/ADA176275. Defense Technical Information Center (ADA176275).

A Database provider (DTIC) and a document number were/are both provided; and by experiment, that very last period after (ADA176275) is still appended even when formatted with your template.

Are there other places to look?


Is this a “thesis” ref type? You said most were, but I need to know exactly which ref type this record is defined as.

Hi Leanne –

It is a stock Chicago 17th Footnote from the Thesis template.

One thing I have discovered, running Mac EndNote X9.3.3: If I go to References → URL → Open URL, the proper URL opens regardless of the period/full stop. Clicking in the example is misdirected to a Citation number not provided.

What are the necessary steps to activate a template change? Right now I make the change, save the change, quit EndNote, launch Endnote, look for the change. Mostly I don’t see it. The times that I have, I don’t know what I did differently. The EndNote guide seems to say just saving it is enough. What is your experience?


Another thing I’ve just noticed is that the Chicago footnote preference set in Author Name is for “first name first.” This too is being ignored.


I almost feel that we need to Zoom and look at your document, your library and your process. DM me if you want to try that, but here are my questions and thoughts.

TLDR – once you digest the below – I believe I can help you adjust everything except - I believe the live URL link in the footnote. I think this is a word/field issue and not EndNote solvable. I wouldn’t worry about it - if it is accessible from your bibliography itself. If it is important to you – it needs to manually be fixed before submission.

So onto the Long Version!

  1. what field are you putting the

        Final Report Jul 1983–Jun 1986

    text into in the thesis record for this entry?

I entered as a thesis type – and was able to generate the missing space because I didn’t know where to put that “note” information. Trying to identify the missing space before that field in the bibliography output. In the footnote template, the field appears in parentheses. See below why this is significant. It can be fixed, but before we worry about that, you need to understand the next item about bibliography output (accessible in EndNote preview) and footnote output (inaccessible to viewing output in EndNote program).

  1. I believe you are copying the text you are providing in above messages, from the bibliography (preview in endnote?) rather than the footnote output in word. I believe this because the bibliography name list is last, first author listing - while the footnote is first last (and the above issue with the “report” text). The preview in EndNote doesn’t show what will appear in the footnote, only what will appear in the bibliography list. You have to check the footnote output in the document’s footnote, you can’t from EndNote. It never previews the output from the footnote. I didn’t make any changes in my output style attached above to the bibliography templates, hence the periods are still in those templates and the missing space before the “final report…” text (which can be fixed too-- once we settle on the other issues).

In Word, I assume you know that you should first enter the text, then insert/add the footnote (or endnote -not Endnote citation) using the word tools-from the word “references” menu- and then moving down to the footnote to insert the EndNote citation into the footnote itself. You can’t just paste the citation in line into the text. This will produce the footnote as defined in the EndNote template, and also give a bibliography listing for the record according to the Bibliography templates. In my windows version of word and my windows version of EndNoteX9.3.3, I get the live URL only in the bibliography list (and it works). My AutoFormat and Autoformat as you type settings in word both have the “internet and network paths with hyperlinks” box checked. But my footnote is just text. I cannot get my word program to make a live URL link without manually editing it, and if I do that, EndNote immediately overwrites it back to plain text. I don’t know why. To change it to a live link, I first have to delink the endnote citations (which is a bad idea, until you are done writing and about to submit). I don’t know why it works in the bibliography but not in the footnotes.

  1. In answer to the problem of edits “not sticking after you save” – If you make changes to your output style and they aren’t there after saving it.

You must save an edited output style to a new name (and change the document to use the newly changed output style). If you use the same name, you have two copies of the output style, one installed in the original write protected location in the program itself, and the other in your user defined folder (defined in “folder locations” in preferences). The program cannot resolve two copies, so it usually defaults to the installed folder copy and not the user edited copy.

Hi Leanne –

A Zoom meeting is fine, and happy to do it, but I don’t know how to DM here. Anyway …

There is no Word document. The end result will be a collated bibliography of 100 DTIC documents at some later date.

All this comes copied from EndNote’s preview, which is labeled Chicago 17th Footnote. Note that it has a live, blue hyperlink with a period inside it. I click on it and generate an website error from the period. We’ll know we’ve succeeded when the period is black.

This is what my reference looks like (very much like yours):

I understand I must make a newly titled style with my edits in it. See the first image, which has original (checked), my (mrt), and your versions. If I select the mrt version (there is only one) my edits are extant inside but don’t reflect in the Preview window. Do you mean that every edit not involving an original requires a new name?

Like you, I am coming to the view that the period issue is a EndNote bug, particularly when Open URL doesn’t throw the error. But I need to get a handle on the possible first.

If you enter a degree (say Master’s) in the Degree field, you don’t need the leading space in the Thesis Type field.

To direct message me here, just click on my name and it will open a message to me - one to one.

but now that I know that you aren’t being flumoxed by footnote issues. you can use any output style – not a footnote style! And I am much more comfortable.

But sticking with what you have.

Have you tried exporting the list you need. – exporting the records from the file menu and choosing an .rtf output, and choosing your output style in the menu will create a file with all the showing references in your library. – now when I do that - none of the urls are active, but when I follow the instructions here, Redirecting – Word seems to autoformat them just fine, even if a period follows the url. (in my windows version of Word 365).

to fix the spacing issue, you want to replace the regular space infront of that field, "thesis type with a separation and link adjacent symbol. – I suspect when you use the Thesis type for “masters” the “degree” field is empty?

Hi Leanne –

I think I got it. I had an epiphany this morning while shaving. The title of the style is “Chicago 17th Footnote." That does not mean (and never did mean) the preview pane is showing me a footnote! In fact it is showing me a bibliographical entry and all my "non-sticky” edits were in the wrong place. That also explains why the "first-name first” issue was there. In Chicago style, bibliographic entries are last-name first, yet footnotes are first-name first. It’s one of the things I harp on with my students.

I fixed the space issue by moving “Final” to Degree and leaving “Report…” as Degree Type with no space.

Finally, the I fixed the URL issue. I changed URL|. Database to URL| Database. The sharp-eyed will note that the period is not there. I don’t care. :sunglasses:

Thank you for all your help. You have taught me a lot with an amazing amount of patience.

…best, Mick

\o/ Yay! sorry it took me so long to figure out why we were talking at cross purposes too!

Now all I have to do is correct about 95 entries. One bite at a time. No rush.

Thanks again.

to move from one field to the other? you can do that in batch with the Tools>change/move/copy command.