Preventing periods from being incorporated in URLs

How can I prevent the period at the end of a bibliographic entry becoming incorporated into the URL hyperlink?

The URL at the end of a citation should read Not  Obviously in the latter, the hyperlink will not work.

In the attached images you can see the Reference Output Style and the Preview of an example citation. As it is shown, I am using a forced separator between the URL field and the period. To my understanding this should work, but obviously it does not. 

I have also tried ’ prior to the period but this simply adds a ’ into the URL.  I have tried Linked Adjacent symbol and a combination of all. None solve the problem. 

BTW I am trying to conform to the Chicago Manual of Style 16th Edition Author-Date (pp.754, 807, 808).

Thanks for your help.

Reference Preview.jpg

Placing the forced separator between the URL and period only means the period won’t appear with the URL, however, the period will appear at the “end” of the entry. That’s why the period continues to appear in the bibliographic entry.

The solution is to delete the last period from the template.

Thanks … but if I delete the period altogether, how is the citation completed with a full stop?  Chicago Manual of Style (and indeed other styles) require citations to be completed with a period. 

Thanks for the correction. Since you’re using the “Electronic Article” template, it seems the URL would be expected to be included - so why is there a “link to adjacent text” next to the URL?

Suggest the following change to the URL section of the template:

Access Date|, URL|.

Thanks, just tried this, but it didn’t change anything. The period at the end still gets incorporated into the hyperlink. It SHOULD read But instead, it reads  A tiny, but infinitely important difference.   

I’ve tested the template layout for Chicago 16th A and B. The hyperlink is correct in that it omits the period from the URL and displays it at the end of the bibliographic reference. 

Are you using the correct output style file?  When modifications to the style have been made the changes are saved to a new output style file that has the word “Copy” added to the file name (e.g., Chicago 16th A Copy). So both EndNote and MS Word should be adjusted to use the new file.

You might try downloading a fresh version of the output style in the event the one you’re using is corrupted. 

Thanks again. The Chicago 16th B file (unaltered) puts the access date after the URL instead of after, which is not in conformance to the manual. So in the Chicago 16th B Copy I have put the accessed date before, which leaves the URL at the end (in accordance with the manual) but then the problem described above arises.

If you have a version of the Chicago 16th B which is correct (has the URL at the end of the citation, following access date, and the period remains outside the URL hyperlink) – which is therefore different from the version I have – would it be possible to get it from you? Or at least copy exactly how it treats these reference types? (As an aside, I’ve been trying to make it work with other reference types such as Online Database and keep encountering the same problem).

Thanks so much.

Hey just further to previous, I’ve found and downloaded the latest version of Chicago 16th B  I’ll test it and let you know what happens.


OK. Bad news. The latest downloaded version of Chicago 16th B reference type for electronic article does have the URL at the end (good) but now TWO problems:

  1. it does not include access date prior to the URL (OK, I can fix this myself)

  2. the period STILL gets sucked up into the URL hyperlink. ARGH. 

See attached image. (NB, I imported the new .ens file into my style library with the name Chicago 16th B NEW so it didn’t write over the original Chicago 16th B.)

How come you seem to be able to see the URL with the period separate to it, but I cannot?  Would it be possible for you to please post a screen shot of a reference preview so that I can at least see that it is possible? And also a screen shot of the reference type template that shows how that reference preview is achieved? Thanks so much!

Here’s a copy (attached) and a direct link to the Chicago-related output styles on the  EndNote support site:  The date for the Chicago 16th B on the website is 10/7/2011 and I think it post-dates the attached output style so if you want the most recent version, use the URL to download the file. 

Also, depending upon your version of EndNote, you can go to the toolbar, select Help, Web Styles Finder - which will launch your web browser and take you to the Endnote support site.

It can take some tinkering to get the templates to do what you want but knowing how really enhances the versatility of the product to suit one’s research needs.

Chicago 16th B.ens (25.2 KB)

Could you provide the complete bibliographic entry so I can replicate it?  Also, what version of EndNote and Word are you using?

Here are screenshots of the record (its in two parts because I have to scroll a long way down to the URL and access date fields). Feel free to abbreviate the long title. Also a .txt file if that helps you import the data.

Endnote X4 and Word Mac:2011

Thanks so much.

ASEAN entry.txt (194 Bytes)

I replicated your ASEAN entry as an “Electronic Article”. I did not modify the Chicago 16th B output style to include the access date but as shown in the attached image, the ending period is “outside” of the URL.

I tested using EndNote X4.0.2 with Windows 7 Professional.  Are your EndNote patches updated?

Ok, thanks for your system and program info. There’s a patch for EndNote X4 users (for Windows and Mac).  Are you running X4 with or without the patch?

If you haven’t installed the patch, here’s the link for info and downloading:

If you are running X4 with the patch installed, suggest you contact Tech Support as this may be a Mac-related issue:

Thanks for that - I’m happy to see that it is working correctly on the Windows machine, at least the required outcome is possible!

I will install the patch, re-start etc and see how it goes.  I’ll contact the mac support guys if the patch doesn’t solve it. I will also have a go on a Windows computer; I should be able to access one tomorrow.

Thanks again, I’ve really appreciated your help.

Sorry there wasn’t a better outcome. Good luck with the patch and if not then … Tech Support.



You guys are up all night, or in a whole different time zone!   – I think this problem is how the word processor is interpreting and converting the hyperlink.  Endnote doesn’t convert the text to a hyperlink? 

(Added in edit after investigation)

Guess not-- I just looked at the endnote preview in windows, and it works, as you said CG.  The windows X4 Chicago 15th B, I tested has the “electronic article” bibliographic template as

Author. Year. Title. Periodical Title| (Issue)|, URL|. (with no link adjacents that I could see)

and it works perfectly in preview and in the bibliography.   

Ravetz, J. 2012. Sociology of science: Keep standards high. Nature (7379),

I am assuming you have checked and you don’t have an inadvertant period in the record? 

I am using a WinXP, Word 2003, Endnote X4.0.2 on my home machine.  so perhaps it is a mac thing?

Update for CG: Installed the patch, and reformated the biblio in the doc using Chicago 16 B New with modification to include the access date prior to the URL. The good news is that the period is now NOT being sucked into the hyperlinke IN THE DOC. However, bizarrely, the preview pane in EndNote is still showing that it is. I can live with this, as long as it is not in the final documents, although it still seems inexplicable. I will notify the mac tech support team. So, in all, thanks so much again for your help.

Leanne: :slight_smile: Yes, I’m in Australia. The issue actually is that there IS a period in the URL when it shouldn’t be (i.e. despite a forced separator). CG has at least helped me eliminate it from the bibliog in the word file, but it is still showing in the EndNote preview pane (I’m using X4 on a Mac OSX Lion).  This is odd, but I can live with it.  At least the hyperlinks now work perfectly in the Word doc.  I will test the same records and style files on a Win machine today and see if the problem manifests - I’m pretty sure it won’t because CG couldn’t replicate it on his Win machine. Just a peculiarity with Mac which I’ll report.

I’m happy to close this off now - thanks for your support.