endnote doesn't find the right reference library in word

hi… I’m a new endnote for mac user and I’ve been having trouble using the cite as your write function. I have created my own endnote library and made it my favourite and I only have that one library open. However, when I try and import citations into word, it comes up with an error message saying that there are no selected items in the frontmost library. I have only one library open and the references have been selected.

I tried importing citations with the sample library and it worked, but still can’t get it to work with my own library. need help!!

Make sure you are in the Library itself and not the search results in the Online Mode, which are not in the library yet?  Scroll down a bit fromthis link, and see the discussion of modes. 

Are you using EndNote X2 and was the library saved as a .enlp package file?  If this is the case, then you are using the unpatched version of EndNote X2.  You would need to download and install the EndNote X2 update as this was one issue that it corrects:


As an alternative, you can save the library using “File > Save a Copy” and make sure that the option to save as a .enlp package file is not checked.  Then use that copy of the library.