Endnote upgrade 20.3 problem

I upgraded to Endnote 20.3 last night and immediately lost the ability to type the first or several letters of an author’s surname, say, “Smi” for Smith, and the library, which is sorted by author, will drop down to the first entry beginning with “Smi.” Instead, it seems either to go to the first entry in the author list or to do nothing, depending on where you are in the sorted list of library entries.

2 Likes

Same here on MacOSX version. I hope that Endnote developers will be more reactive than to correct the “lost space” bug ! It is very annoying !

I’m sorry that in my original report on the 20.3 Endnote upgrade problem that I failed to say that I was using an iMac running OX 12.3.1. That said, I suppose it’s good to know that someone else on a Mac is having the same problem and that mine isn’t unique. Yes, it is very annoying.

Same problem here. Too many bugs, so I’ve requested a refund and reverted to X9. Still, headaches there because I must change a few settings. I hope others complain and ask Endnote to await releasing new versions until fully tested with users in mind.

Same here. In addition, I have lost the ability to quickly attach a pdf. Moreover, the file will not stay sorted from where I sorted it last time so every time I open it, I have to resort it. I want to go back to the prior version and regret that I updated it.

1 Like

Observe the same problem with MacOS 11.6.5.

Moreover, after starting Endnote, library is always sorted by record number, i.e. showing the oldest entries first.

It seems like the “Sort Library” settings are automatically deleted after closing the application, even after entering them manually: After reopening, all parameters are set to “None” again.

As far as I have tested until now, these issues don’t apply to the Windows version.

Well, not exactly.
My environs: Win 10 pro, PC i7 10th gen 32gb ram, storage in all ssds (no spinners)
First: when I updated X9 to X9.3 by an automated prompt some weeks ago everything started:

  1. Lost the link with MSWord2021 CWYW
  2. Not able to import a pdf, but it crashed every time
  3. Not able to find the pdf in the viewer pane. If I see one and tried to open it crashed.
  4. Not able to search by “Online Search”, it also crashed every time
    EndNote staff remotely helped very patiently and courteously, for that I am very thankful
    however, it has not solved yet essentially
    Second: tried to upgrade to 20 to see if the issues would go away.
  5. It seemed to recovered CWYW partially, in that it allows to insert inline citation {name,year}, but when I toggled “Instant Formatting Off” in MS word to “…ON”, it crashed every time.
  6. Other issue remain the same
    Third: Uninstalled EN20 and went back to EN9.3
    Current issue:
  7. Not able to import a pdf, but it crashes every time
  8. Not able to search by “Online Search”, it also crashes every time
  9. CWYW partly works in that I can only insert citation in-line but still not able to toggle as I mentioned above in MSword.
    As far as I search on-line, I have not been able to identify something to solve these yet.

I appreciate very much anyone’s idea!

Ok, that’s curious. I have migrated more than one installation from X9 to X9.3 and later from X9.3 to X20 without an issue. And now, I can’t reproduce any of your issues either with EN 20.3. I fear, these are special to your installation.

Thank you for your attention to my EndNote issue.
All of the following issues were solved:

  1. EndNote crashes when I click the “Online Search Mode”, the globe icon. << Fixed*
  2. EndNote crashes when I try to import a pdf of research paper. << Fixed*
  3. EndNote crashes when I try to “Find reference updates” << Fixed*
  4. EndNote crashes when I toggle “Instant Formatting is Off” to “Instant Formatting is ON” in MS Word 2021, and MSWord 2021 reports an error: “Remote procedure call failed”. However, if I toggle back to “…Off”, EndNote will back again as if nothing happened. << Fixed*
    *Fixed @ 05/03/22 – Steps taken to fix:
  5. Noticed that the MSWord docx I was editing as a research dairy frequently showed error:
    “Word cannot complete the save due to a file permission error.
    (E:…\AutoRecovery save of NOTES1.asd)”
    (NOTES1.docx is currently working file with references)
  6. E:\ is the drive for temporary folders of Windows system files TEMP and TMP which made me think it might be a saving issue of this file. Thus checked the MS Word Options > Save > Save Documents > Browse (button click) which took me to the AutoRecover file location of the WORDTMP directory.
  7. Right click of the disk on the left pane > Properties > Security tab > select Users on the “Group or user names” > Edit (button) > select again Users > place check mark on “Full Control” in the bottom pane > Apply (button) > OK (button) > OK (button) again.
  8. Go back to MS Word Options > Save > Cache Settings > “Delete cached files” (button) > OK
    Hope the above helps some EN users on PCs
    +++++
    Little background:
    EndNote X9.3.3 (Tried EN20.3 in the process before figuring out as above)
    MSWord 2021 desktop
    EndNote.exe is in C:\ as usual
    Working directories is in F: drive (not in C:) in order to preserve C: as much as possible to avoid disturbance while adding citations, pdfs, etc and preserve my local libraries in case PC issues including upgrading (e.g., swapping disks etc)

I find the same bugs as pointed out here using both Intel and Silicon Macs Monterey, i.e.:

  1. there is no more possible to set the library sorting settings. Every time I open the library I have to re-sort it;
  2. there is no ability to search the library by typing the first letters of an author’s surname.
    Even worse, I lost all my group set labels, and all the groups dropped into one category ‘MY GROUPS’ and got mixed up.
1 Like