EndNote Word Error in Find & Insert My References

Hello everyone

I cannot insert the majority of my library in my Word documents, regardless of whether I have just saved the reference or if it is dated.

This is clearer by looking at the image I am attaching to this post.

When I click on insert a citation and I type a keyword or an author in the search bar systemically an EndNote Error window appears.

Yet I see the references related to the keyword or the author I just wrote behind the error window of EndNote20. When I click “Ok”, these quotes disappear.
I tried typing everything but even when I put a single letter like “p” it gives me this error message. I tried refreshing all my references in EndNote, I also sorted all the duplicates. But nothing helps, I’m stuck I can’t select my references although I can see them.  I have also converted my citations and bibliography to unformatted citations. I changed the style etc. But nothing changes.

I must say this is the first time I use EndNote, before I used Mendeley.

A big thank you in advance for your answers and suggestions

up please!

I highly recommend you reach out to the endnote.com support because it is likely that none of us other users have a clue what is going on.  

Do you have both, EndNote and Mendely installed on your system?

If yes, deactivate Mendeley in the Word coms and you will succeed. Here is the macro that I use:

Sub TurnOffMendeley()
 ' Toggle Mendeley temporarily
 ' © Christian Wolkersdorfer c.wolke@web.de
 ' 2021-06-01 initial version
' 2021-06-20 mendeley version will now be detected
 ' ensure Mendeley version is correct
 wordStartupPath = Environ("appdata") & "\Microsoft\Word\STARTUP\"
menVersion = Dir(wordStartupPath & "Mendeley-*.dotm")
menPath = wordStartupPath & menVersion
AddIns(menPath).Installed = _
  Not (AddIns(menPath).Installed)

End Sub

edit: code optimized for other Mendeley versions

1 Like

I had, I think, the same problem and after 2 hours of frustration found a solution that worked. 

In the properties of EndNote 20 application file, allow ‘Write’ in security settings. 

C:\Program Files (x86)\EndNote application file - right click - properties - security tab - Edit - tick ‘Write’ box in allow column - apply - ok.

I don’t know if this will work for others, but thought it worth sharing.