EndNote X.0.2 and Word 2004 (11.4.2) Mac - "Compile error in hidden module: ThisDocument"

Endnote X (10.0.2), Office 2004 (11.4.2)

I have a computer that was displaying the error “Compile error in hidden module: ThisDocument” when trying to run Endnote X from the Tools menu.

I upgraded EN and Office to most recent versions, deleted referenced preferences from endnote.com’s support pages, and voila! The EN toolbar reappeared, and calling EN from Tools menu seemed to work.

However, quitting and relaunching Word, then trying to call EN from Tools or the EN toolbar creates the same error. VBA editor works, and have recreated VBA prefs file among others.

After further digging, I have discovered that the offending file is “~/Library/Preferences/Microsoft/Office Registration Cache 11” however, no info is available on this file here or on MS’ Mac or main site. Deleting this file will allow Word and EN to work again, ONCE. Then the file needs deleting again to eliminate the above error.

WHAT THE HECK is going on here? The only caveat about this setup is that the users home folder on an NFS volume. Otherwise all privileges and local/remote prefs directories appear to be in order.

What’s causing this file to corrupt, and what the heck file is this - license file or plugin registry cache??  Is EndNote causing this and would upgrading to EN X1 solve it?



This is a problem with Word when the home folder is on a different drive, the Visual Basic file will become corrupted.  You would want to delete the file and start Word.  Then before you close Word, lock the Office Registration Cache 11 file so it can not be overwritten with the corrupt data. 

Thanks Peter,

Your suggestion definitely helped narrow the search.  However, I could not get the “make read-only” trick to work.  No matter what when Word restarted, even with “Office Registration Cache 11” as read-only, I would get the same error.

However, our local linux guru helped try a few things to no avail:

>redirect the local ~/Library/Preferences/Microsoft to the remote ~/ 

>redirect the remote user’s ~/Library/Preferences/Microsoft back to the local user’s ~/ directory

For some reason, Word will not follow the links.

What finally worked was creating a “cleanup” shell script which deletes all known copies of “Office Registration Cache 11.”  This runs as an OS login item (modifying .bashrc created issues with X11 apps) and requires the user to run every time after quitting or before starting Word.  Ugly but effective.

Thanks again for your input!

very useful. but is it possible to run the clean script every time start word (or close word)?

We tried editing the .bashrc to include an app call to Word, and it didn’t work.  I wasn’t doing the heavy lifting on the Linux side, so not sure what he tried for that.

You could possibly add some sort of folder action or other Finder script to lauch the clean script, then run Word…

You can combine the bash script and applescript.  Since Mac OSX is based on FreeBSD, you can create a bash script to delete the file.  Then you can make an applescript to call the script and then start Word.  Though thinking about it, you could do it all with applescript, just replace the first line with the applescript for deleting the file, which I can not think of off the top of my head:

do shell script “/path_to_script/rm_reg_cache.sh” 

tell application “Finder”

open application file “Microsoft Word” of folder “Microsoft Office 2004” of folder “Applications” of startup disk

end tell 

hi, further tests have shown that it is endnote library cuased this problem. if you make sure that the endnote liberay is available before starting word, everything works fine.

Well, we’ve created a link in the user’s home to point to the local Endnote library, so Endnote doesn’t complain.

But thinking on it further it might make sense that since Word refused to follow symbolic links, if the library isn’t already open in EN then the whole works gums up.

Worth a try, thanks!  I’ll look into that.

I have Endnote X1 for Mac, Office 2004 Version 11.5 and running MacOS 10.4.11  and this problem still exists. I have tried everything suggested here and none of them have helped. Any input would be much appreciated as we have about 400 people with the same problem at the company right now.