Word 2008 and EndNote X2 Error: COM exception

When I open Word (a new or saved file), I get a message that says:

A COM exception has occurred.
Index refers beyond end of list

The title box of this error message is EndNote X1, which is strange because I have X2 installed.

This only happens when I have CWYW installed. Until I placed the ‘EndNote CWYW Commands.dot’ file in the Word Startup folder, the EndNote X2 menu did not appear in “Tools” in Word.  After putting that file there, I see the menu, but none of the options do anything.

I’m running Mac OS 10.5.6, with Word 12.1.5, and EndNote X2.0.1 (all updates installed).

I’ve tried performing the steps mentioned in the FAQs, but nothing helps.

I had the same issue, and was unable to address it talking to the support phone line. However, one thing that seems to work so far is the following:

I removed the ~/Library/Preferences/Microsoft/Office 2008 (the whole folder!), as indicated here: Mac office forum post. I also deleted all Endnote files/installations I could find, and completely reinstalled X2, now NOT installing any updates. I am not sure what solved the issue, but it is working for now…

(Note that this is in addition to lots of other attempted ‘solutions’, which may or may not have contributed to the final outcome)

Message Edited by pcavdwel on 02-12-2010 01:11 PM

I had the issue with a document in Word 2008 and EndNote X3. I solved it by opening the document in Word 2004, saving it as an .rtf and then opening the rtf in Word 2008 and resaving as a normal document.