Endnote X2 and Pages 09, in-text citations won't appear


I am using Endnote X2 and Pages 09, and am trying to insert in-text citations. When I select 'Insert Endnote citation" in Pages, and then the relevant reference in Endnote, the citation does not appear in my document. An empty bibliography appears at the bottom of the document, and when I go into “Edit, manage citations”, my reference is listed there. However, it is not visible in the document, or in the bibliography. 

Any ideas how I can fix this?



You will want to try switching output styles in Pages. EndNote does have a few styles that do not include a citation definition, such as the “Show All” output style or the “Chicago 15th A” output style.

You can switch styles in Pages using the following steps:

You can go to Edit then EndNote Citations then Bibliography Format and select a different style from the list.

The list will only include favorite styles selected in EndNote. If you have limited options here or the style you want to use is not listed then save your work in Pages and close Pages, in EndNote go to Edit then Output Styles then Open Style Manager, you can mark the boxes in front of a style to make it a favorite, close the Style Manager, reopen Pages and now you should have the style as an option.


I am quite puzzled by the change in output style in Pages 09 when I use in text citation option. The reference library shows the new font I have selected and also the author name appears in small cases. When the citation is used in Pages however the font changes as well as the author last name appears all caps?!

Also another problem I have is with Reference Types. For example I tried using Government document and also Report types for the reference below. 

World Bank (2008), World Development Indicators 2008, Washington DC: World Bank

However, while outputting it appears as

(2008) World Development Indicators. IN BANK, W. (Ed.). Washington DC, World Bank.

It is proving to be problematic if I fill in the author or leave it blank. I have tried filling and not filling other sections such as Publisher, Government Body etc… but it still does not appear as it should!



and enter World Bank with a trailing comma in the author field.