EndNote X2 error message "could not initialize database support"


I just installed EndNote X2 on my new laptop, running on Windows Vista. When I tried to open my existing EndNote libraries using EndNote X2, I always get the error message "“could not initialize database support”. The same error message also appear when I open the new library I just created using EndNote X2. However, I noticed that if I launch EndNote before opening up any library, then there is no problem. I don’t want to deal with the error message every time I open an library. Do you know how to solve the problem? Thanks!

Message Edited by yung on 10-16-2008 11:23 AM

I have this problem also. Does anyone have an explanation/fix?

I have the same problem. I have to go and present EndNote X2 before state managers this Wednesday (November 5th, 2008) and I do not want EndNote to look like a flimsy software. Can anyone help?

same problem, maybe it is a flimsy software!

I have been a faithful customer of EndNote since version 6. I introduced countless of my collegues to this software. Lately, I fought to have my department buy 10 copies. I had to fight so that EndNote be selected over Zotero. I am less and less sure that we made the right decision.

Despite all the messages on the forums about this specific problem and all the views of this post; no one at Thomson Reuters even contacted me. In a week, I will have to present this software again in a big state agency in Trenton, NJ. For a second time, EndNote will look like an half-baked beta version, the second I will start the program.



If you are on Windows Vista, make sure you are not placing libraries in Program Files.  Because of restrictions Vista uses, opening libraries anywhere in Program Files will generate this error.

It has never been recommended to open an EndNote library by double clicking on it.  The recommended way to open a library is that you start EndNote and then open the library.  If you want a specific library to open when you start EndNote you would:

  1. Start EndNote

  2. Open the library

  3. Go to “Edit > Preferences”

  4. With EndNote X2 you would need to set “When EndNote Starts” to “Open the specified libraries”

  5. Click on “Add Open Libraries”

  6. Click OK

Then when you start EndNote the library will open.

If you need Technical Support to contact you about an issue you are having you would want to contact Technical Support directly at:


Just a reminder from a user… This is a users forum, not tech support.  For a detailed specific solution, I would recommend contacting them directly thru the web site submission. 

“It has never been recommended to open an EndNote library by double clicking on it.”

Well, maybe that could be a nice “feature” to add to your next release. It would make it look like 21st century software… That is if your software programmers care about a humble customer suggestion.


Now seriously, thanks for the reply, I’ll try customer support. And no, I didn’t put EndNote libraries in Program Files (not that stupid…). 

I used both EndNote and RefMan for about 10 years… and I won’t dismiss a release easily, but not being able to open a library (using the RECOMMENDED way) right off the bat it’s very annoying (fresh Vaio, Vista and Endnote X2).

When I try to open an Endnote reference library in Vista with Endnote X.0.2 (Bld 2283) 1 it returns the following error:

“This library appears to be damaged. Please verify that no other has this library simultaneously with write access. If this error persists after restarting EndNote, please repair the library using the Recover Library command on the Toolsmenu.”

Using the Recovering Tool does not help.
Anyone knows of a quick fix?


Are you sure it is in a directory that has write access (i.e. it isn’t in the Programs folder).

Yes, the libraries are in My Documents (NOT in Program Files). I checked the permissions and they all (both the library and the files in the Data folder) have writing permissions. They have exactly the same attributes as the files from a freshly empty library I created with EndNote X2.

The library I’m trying to open was created on a PC with EndNote version 11. I also tried recover and import to no avail.

Two words: Tech support!:cry:

It’s actually an installation issue.  In the program file, you can double click the .exe file and it will open EndNote but will give you the “could not initialize database support.”  You have to make sure that you installed it correctly by opening the ENX2Inst file from the program file.  This should properly install EndNote and fix the problem. 

The reason you shouldn’t double click on a file to open it is because then Windows gets to decide what to do with the file. Winows can choose to open files with specific rights or software flags that can cause issues. This can happen in ANY program. It used to happen to me in Word all the time.

Vista’s UAC doesn’t just lock the program files folder. It’ll lock many folders on the C: drive. It’s best to save files you edit often in your Documents folder or on the Desktop.

Alternately you can try turning off UAC to see if that makes a difference.