EndNote X4 fails to update the PDF index.

For a very long time I have been a proudly EndNote user. Recently the IT people of The University of Nottingham installed the EndNote X4 version on my computer and for my surprise it cannot open the endnote file I was using with EndNote X3. It starts saying that is updating the pdf index and then it automatically quits. The only way I can open the file is if I open it first in X3 and with it open, open again the file with X4. I get a message in X4 saying that the changes cannot be saved because the file is already being changed with another software, but I can see all the references and pdf’s with no problem.

What can I do to make X4 work? EndNote is a crucial part of my workflow and I would be really disappointed if I had to go to any other solution.

Kind regards


Ok, I finally manage to fix it.

If you organise (as I do) the pdf’s inside the EndNote database you should have: “.enl” file and a “.Data” folder. Inside the “.Data” folder you should have the following folders: “PDF”, “rdb” and “Trash”. Delete the “rdb”  and “Trash” folder, if there is any other folder or file delete them, the only folder you will need is the “PDF” one. Now start EndNote X4 and your problem should be solved.


I am very glad this worked for you!

I would, however, encourage people to be cautious before following these steps. Please make sure that you have backed up both your .enl and the .data folder , as deleting the contents of the .data folder is permanent and can cause irreparable library damage and data loss. In our experience, while these steps may help certain users, it may worsen the problems for others, so please do back up first so that you can try other solutions as well.

If these steps do not work and you are still experiencing this issue with X4 failing while updating the PDF index, please immediately contact Thomson Reuters support by phone or email:


I hope this helps!

PLEASE PAY ATTENTION TO THOMSON REUTERS WARNING! I tried the “solution,” and it worked inasmuch as EndNote 4 finally started up (after crashing many times as has been happening with a lot of people). However, my library was pretty scrambled–I’ve no idea what that rdb folder is, but it’s obviously very important! Fortunately, I had saved the rdb folder on my desktop, and reinserting it over the “new” one got things back in line.

Looking forward to a solution, and in the meantime sticking with EndNote 3.

Cchester, Why don’t you contact us over in Technical Support? We do have a workaround in support that should get this library open for you in X4 Mac without the problems of the above solution.

It’s still not perfect as you wouldn’t be able to use it the compressed library feature, but in all other ways it should function pretty much normally in X4.

Please open a case with us at: http://endnote.com/support/entechform.asp at your earliest convenience and we’d be more than happy to help you with this.

Deleting other folders excluding pdf will make it work, but you will loose any other information including groups and other (feature of endnote x3 and x4).  I found grouping references helpful and hope Endnote technical support will fix this issue.  This is very annoying and should have been fixed at the first place before releasing into market.

Endnote x4 window has no issue.  Mac version does not work properly.  Please fix it as soon as possible.