PDF indexing problem in upgrade from x4.0.1 to x4.0.2

 I believe there is a serious problem in the latest x4.0.2 Windows release. I attempted to install it as directed to replace my current x4.0.1 version, and it hung up on initially opening my library database on “updating pdf index.” I have had several exchanges with Thomson Technical Support. They took my library database file and claimed to have opened it successfully but on return, the same problem developed when I tried to open it on my local machine. They then converted it to an RIS text file and had me import that into a new library, but it could not open because the same “updating pdf index” problem. I appreciate their efforts but they have not solved the problem.

IMHO,  there is a real flaw in the 4.0.2 release that needs to be addressed, and anyone should be very wary of upgrading. My Endnote library database is very stable and longstanding. I have used EndNote for over 15 years on a daily basis, and I have purchased and installed (several licenses of) every version, update, and patch from the original version 2 through x4.0.1. I have built and maintain a large library data base of 28,000 records with an extensive pdf attachment library of 12,000 files (absolute not relative links), and I have never had a single problem with any upgrade on a succession of machines and OS (presently an Acer Timeline X with Intel Core i7 and 4 GB RM, with Windows 7 Pro 64 bit).  This is a first, and it is unnerving. It is also frustrating that Thomson will not respond to my request for a link to the x4.0.1 so I can go back to that version and be able to use the libraary database.

I know there is another thread in this Forum about a similar problem of “updating pdf index” but that refers to an attempted upgrade from x 3 to x4. It is true that removing the rdb subfolder, as someone recommends, will force a new rdb folder of MySQL and other files to be created and the library will open but with loss of all term lists, groups, and smart groups, which is a very significant loss for a longstanding library.

I wonder if the problem is due to the absolute location of the PDFs?  Sending your library to Tech Support wouldn’t have included those PDFs and so they wouldn’t have been indexed?

Hello - I imagine that indexing 12,000 PDFs will take some time but since it seems to be hanging, a closer look makes sense. If you have a convenient window where you can let the indexing run its course, does it eventually finish? This may require a few hours. We encountered performance issues that were often PDF specific but these were addressed in the X4.0.2 update. It’s possible that one or more PDFs in your library exhibit new conditions that we haven’t encountered yet…

Does it happen consistently with other libraries or only this one (this may not be relevant if you only work with one library)?

 - Mathilda, the EndNote team