EndNote X5 bug

I just upgraded to EndNote X5 and believe I’ve found a bug. In EndNote X4 I could right click on a citation and that would display a dropdown menu then select File Attachments > Attach File in order to attach a pdf to the reference. Although that appears in X5, when I try to attach a file, it appears as if nothing happens. Repeating the procedure asks if I now want to replace the allegedly attached file or add a new one. Examining the reference, however, indicates the no files are attached. The only way I can attach a file, at this time, is to open the new PDF & Quick File Edit tab and attach it there.

I think you will find that clicking off that record (and respond to the query if you should save the record)  and onto it again will reveal the attachment.  I think this behavior has been reported.  Some of the other ways to attach the PDF do not seem to require the save step, for example dragging and dropping the file onto a record, so yes, I think it is an inconsistent behavior.

Leanne is correct. You need to move to another record or force an explicit save for the attachment to appear in the library list. We are investigating it.

 - Mathilda, the EndNote team

Yes, I’ve confirmed that if I click off the record, respond to the prompt to save it, go to a different record, and then return, the file now shows as attached. Keeping my fingers crossed this will be fixed soon :wink:

I believe I may have found another bug related to .pdfs. When openning an attached .pdf using Acrobat (and not in the New PDF & Quick Edit feature, when making changes and the trying to save the document again, it is necessare to close EndNote first! :frowning: Alhough the new feature is useful, I still prefer to open files in Acrobat as they easier to read (because it’s possible to have a much larger window to view the file in.

Actually, you shouldn’t need to close Endnote. Make sure that reference doesn’t have focus in the library list and then save the changes in Adobe. Also, if you are primarily using an external PDF viewer, you can turn the EndNote PDF viewer off in Preferences. The issue is cause by EndNote having opened the PDF first in the viewer so it’s a file permission issue. This is another issue we are investigating.

  • Mathilda, the EndNote team

Thanks, Mathilda. I’ll turn off the PDF viewer (although it’s handy for glancing at the file, I do prefer using Acrobat).