Endnote X9 CWYW - blank lines in search (macOS 10.14)


I have never experienced this before, but using CWYW in Word 2016 to insert a citation results in blank lines in the search field. This is very strange, because I noticed that just typing a single letter gives results. If you click in the blank search results window, or just use arrow keys you will se that the results are there, since the preview of the selected line at the bottom is correct! And the citation is being inserted in the Word document…

Very annoying nonethless. Has anyone else experienced this? This mac was just updated to 10.14 from 10.11. Endnote X9 was already installed. I tried to delete user preferences in the home Library folder and to create a new library, with the same result.

Word 2016 was just installed, so it must have been the most recent version, most probably 16.19.0. I also tried to run the customizer to reinstall CWYW, but it did not help :frowning:

Hi there,

I have just the same problem on my Mac (Word 16.25, Endnote X9.1.1). When I am searching for an author I cannot see any entries in the upper field of the “find citation” box. As there are entries in the lower box it seems that the search results are simply not displayed in the upper box. When I close the box and re-open it the search results are displayed correctely.

Is the a solution for this problem?

Not a solution, but confirmed on X8.2 and X9.1.1.

You can click on the invisible entries in the upper box, and use the cursor keys to move up and down.

I do have the same problem for some months now, still there is no solution yet…

I have just upgraded to X9.2. However, this did not solve the problem …

I have now upgraded to macOS 10.15, EndNote X9.3.1 and Word 16.29.1

However, the problem with the blank linkes in search is not solved.

Does anyone have the same problems? Is there a solution for my problem?

Yes, I think this issue still occurs in EndNote X9.3.1. I *think* it was somewhat better in X9.2, but I am not sure. Just installed X9.3.1 in Mojave, and had those blank results again. Resizing the window is a workaround, but not a good one. Double checked under security & privacy that both Word and Endnote was enabled under Automation.