EndNoteX2 to excel in columns not all info in a row


Need to export the whole database into an excel file. I need to have columns so all titles, authors, etc will be headings.

Have tried but I only get everything in a row. Need it to be able to import it into a web database that do not support EndNote import.

Anyone knows how to do it?? Have search the web for it but cannot find any solution.

What do you mean by “everything in a row”? Do you have all the data in one row, or do you have each entry in each row (expected result by comma-delimited or tab-delimited export)?

I would like to find a function so I could export all entries. After exporting them I would like to open the file and have all entries in columns like a database so I could import them into a web database. Have tried to “copy formatted” and then paste into an excel but then I get all entries, after each other, in column A.


What I want is to have
     A                B         C        D
1   Autohor     Year     Title    etc

2   Author 1          2006       Clin
3   Author 2          2005       Clinic
4     etc                 etc          etc


Have also tried to export to txt file and then open it up in excel and import it but it doesn’t come up as I want it.

Have you tried Tab Delimited export, using “Tab Delimited” as output style? You have to tweak the style such that only fields you want to export are included in the Bibliography template. Otherwise, you’ll see all the field data exported, and the keywords data which contains carriage return code won’t be in the same row in excel.

As to the colum title in the row #1, you probably need to manually type in the excel or make a EN entry that has the column title in each field. Manually typing would be just easy because it is one time job.

Anyway, “Tab Delimited” output style should do the job for the export output you want.

Message Edited by myoshigi on 03-12-2009 11:44 AM

Oki, then i wont work anyway as I need to export the abstract part as well and that one will contain carraige returns.

Means that I have to copy and paste evrything into excel…:mansad:

Thanks for your help.

It won’t be too bad, if you combine some text editors. You can format output style such that you have three or four carriage returns after abstract. Then, replace single carriage return with a space using text editor. After that, replace three or four consecutive spaces with a tab.

Another choice is to use some database software like Filemaker or MS Access. I believe Endnote export to Filemaker would be easier and much more robust.

In any case, this kind of import/export business requires some understanding and experience for both sides (exporting software and importing software).

Wouldn’t  it work to replace the paragraph breaks (^p) with line breaks (^l)(that’s an ell)? 

for details about MSAccess converstion, see http://community.thomsonreuters.com/ts/board/message?board.id=en-files&message.id=508&query.id=218034#M508 which might have some other tips.

It would. Export and read by MS Word, tuning on the “Show all formatting marks”. I don’t know the carriage return is really in the the abstract. As far as my abstracts of several thousands from Pubmed, none of them have carriage return.

Have come so far so I can export and import to excel if I do not include keywords which imports to different rows for each key-word and then mix up the rest completely. Abstract is no problem as it comes up in one row.

Have used the guide below and have exported the database and then imported it again but still the keywords seem to have CR. If anyone has an output style that works with key-words please let me know how you solved it.

In your endnote library (or on a copy, if you prefer) replace the CRs with semi-colons in the Keyword field. 

Have tried that but a CR is inserted as default and I cannot get rid of it. If exports with ; and a CR even though the template has no CR. I’ll soon give up…

Did you use “Change Text” command in Endnote to replace all CR with semicolon in Keywords field? Of course, make sure you do this after making a backup copy.

Make a copy of your library. 

Edit, Change Text, select field: Keywords (or leave as all fields) and put the Carriage return (from the pull down menu on the right upper corner) in the top box and replace with ;<space>

Thank you Leanne. That solved my problem. No need to export and import it again to get rid of CRs.


Hello all:

I am having a similar problem, but with Endnot 9.  As I am new to the software, I assume there is some minute detail I have missed in the extensive Google and forum search processes.

I have tried several times, all unsuccessfully to save the Endnote database in a format that is easily accessible in the Excel or Access formats.  While I was able to save the library as a .txt format, I was unable to then reopen it in Endnote (which one respondent said would remove the carriage returns responsible for causing all the unnecessary splits in the data across cellse), or in Excel (using the Data import feature).  I am running MS Office 2007, and there seems to be only one option to import any data, and it does not work for me after setting up a database much like Maritha’s example, i.e.: author, date, journal, title, etc.

Having exhausted what appears to be all the available options, I have resorted to submitting this question to the forum in hopes that some more experienced individual will be able to help me.  Thanks in advance!


I meant  ;<space> to indicate that you needed a semi-colon followed by a space. not the word itself:smiley:

Hello Darenne,

We could be of some help, but you have to elaborate a little bit more what you are trying to do. Do you want to export from EN and import to Excel, or the other way around?

Import and Export from Endnote is controlled by Filter and Style, respectively. You need to set up import Filter such that your .txt file is imported to EN correctly. Likewise, you need to set up Style file that matches with your need.

Are you exporting reference data from EN, find/replace CR or LF in the .txt file using Word, and import to EN again? At least you could use “Change Text” function in EN to replace CR.

So, please tell us what you are trying to do, first.

Hi there:

Thanks for the confirmation Leanne!

I am trying to export from Endnote and import into Excel.  I tried to use MS Word to replace the CR; I also tried change text to remove the CRs, but perhaps I went about this wrong.  However, I am not sure if this even worked because for some reason, I am unable to import back into EN upon making all of my changes.  Perhaps you could reiterate?  I know this has been covered thoroughly here, but I cannot get it to work.

I altered the Style to suit my needs, including Journal, Date, Author, Year, Article title, etc and created an Excel spreadsheet that had matching columns with these headings.  Unfortunately, for whatever reason, this method did not work either and I spent hours on this yesterday, only to throw up my hands in utter confusion, as it does not seem like it should be this hard! :slight_smile:

Thanks very much myoshigi; please let me know if there is anything further you need clarification on.  Your help would be GREATLY appreciated. 

Okay, now I know more about what you need to do (still need more info, but let’s figure them out later).

So, when you use import command in Excel, you use tab as a delimiter, right? This means you need to export from EN as “tab delimited text”. You can use comma as field delimiter (CSV format), but I don’t recommend it, because your title and authors may have comma. Important thing you need to know here is, tab (or comma) is a field delimiter and CR is a record delimiter.

First,  make a simple style like this:


Then, select references you want to export, and use copy formatted commnad (Ctrl + K) from your EN library.

Go to word, from Edit, “Paste special” and “Unformatted text”. It is better to turn on “All” in the Word’s Tools/Option/View/Formatting marks, to see all the formatting marks. Make sure you have all the tabs between field and CR at the end of each line. This means, each line corresponds to each record. Save this document as xxx.txt format. Then, import this .txt document using Excel. Do you see what you want?

Once you work this simple thing out, you can add more fields to the Style template, like Date, Journal, Keywords, etc and change the order of these fields. But, if you include Keyword field or other fields that contain CR, import will screw up because Excel considers CR as the delimiter between records. You have to replace CR with something like ; (semicolon) within EN, such that CR is not found except for deliminating records (single line - single record).

So, my suggestion is to work first with simple style, fields that don’t have CR, and make sure your export/import work as expected. 

If you still have problems, please let us know.

Message Edited by myoshigi on 06-30-2009 08:17 AM

Oh my goodness, I think it works!  I selected only a few documents in order to try it out, and it imported to Excel with no problem!  Thanks so much!  Going to attempt the entire library now (this is the smallest of the archives I am trying to do this with).  The only problem is with a book section (all the others are journal articles), which did not go into Excel as expected, but will see if the other journal articles work.  Will follow up.  Thanks so very much for your help!