EndNoteX2, Windows server 2003, MS Office 2003. Invalid class string

 Under user accounts I have a problem with ‘invalid class string’ invoking X2 from Word 2003. I Installed EN X2 at MS Windows Server 2003 Standard Edition under Administrator account, and under Administrator account every thing work fine.

I’ve tried to run EndNote.exe under Administrator rights, I’ve tried to follow recommendations written at http://www.endnote.com/support/faqs/CWYW/faq13.asp, but it doesn’t help.

Any other solutions?

Thanks a lot.


It sounds like the individual user accounts may still have an older EndNote add-in loading when Word starts.  To verify this, log in as one of the users. Next, in Word, click on “Tools>Templates and Add-ins” and take note of what is listed on this window below where it states “Checked items are currently loaded”.  Please let us know what you find.

Jimmy McColery
Customer Technical Support Representative Scientific

Thomson Reuters
Phone: +1 800 336 4474
ResearchSoft Product Support


Currently loaded are the following add-ins:

MathType Commands 5 for Word.dot and MathPage.wll


RM11Cwyw.dot & wll (doesn’t work also under user account)

EndNote Cwyw.dot and EndNote Web Cwyw.dot