WORD - Endnote-problem

Have installed Endnote X2 with a user that was administrator. When it had finished installing I logged the user off, made her a non-administrator and then logged her on again. When she started WORD (2003) the connection to Endnote was ok, and everything worked. But when she started Endnote first, the connection to Word was lost. An error-message saying “Invalid Class String” appeared…

If I then run endnote X2 as an admin again, the connection reappears (when starting Word first).

And I’ve tried the few solutions which Endnote’s suggest…with no luck.

The user log on to a domain as a regular user…

How to fix this?

I guess this might help…

"There’s a fix to the Invalid Class String problem on the Endnote web site here:




1 Like

Have tried that with no success. The thing is that if I open endnote from word it all seems to be alright. But if I open Endnote first I get the “invalid class string”. So I tell all users to never open Endnote X2 first, but ALWAYS open it from Word.

If one open Endnote first…one have to start it as an administrator for it again to work properly. But then, of course, open it from word again…

This seems to be to ppl that have had earlier versions of Endnote installed on their profile. And I have deleted ALL files/folders of endnote before installing the new version.

So a conclusion…dont know :frowning:

I have the same problem.  It is really annoying.

I’ve discovered a workaround.  There should be a registry key called:

Windows Registry Editor Version 5.00



On computers where this exists the ‘insert citation’ works, on ones where it doesn’t the ‘invalid class tring’ happens.  I discovered this from using Sysinternals Process Monitor and watching for errors.

When I open Endnote X2 this key is deleted!  I re-merged a reg file and again when I opened Enx2 the key is deleted, so I have had to merge it then add a custom advanced deny delete permission for the loal machine group everyone on that key in the registry.

I now have to work out a way of globally merging and applying the deny permission for all PCs on my network.

Hope that helps .