Error Message: "A COM exception has occurred. Object has been deleted"

I have just received EndNote X2, to upgrade from 9. Since I installed the test version, I keep getting the following error message in a pop-up window under Word:  “A COM exception has occurred. Object has been deleted”. I have and English Word 2008 12.1.3 build 080930 (the latest), Mac OS X 10.5.5 (French). After I upgraded to X2.01 It was to a point I could not work on a file, because I had to click on the stupid window all the time. I thus deleted Word and EndNote preferences, reinstalled the “EndNote CWYW Word 2008.bundle” (I tried to remove it, and use the “Customizer” to reinstall after quitting Word and EndNote, but it did not do it, I had to drag it by hand, although my Office directory is standard! The .dot files in application support seems to be there). The message occurs even if the file I open do not contain any EndNote fields, some have “Track Change” or “Comments” information and some not. The only other Word PlugIn I have is Adobe PDFMaker 8.1

Thanks for the Help!

1 Like

Same problem here- Word 2008 build, OSX 10.5.5 (English) and EndNote X2 2.0.1.

Whenever certain Word files are open, I also keep getting the same error message.

And if I select Tools- EndNote X2- Format Bibliography in that file, whether or not it has any references, it crashes word.

I tried saving the file as an rtf.  When I opened the rtf in Word, I did not get the error.  But when I saved it from Word back as a .doc, then reopened the .doc- same errors again.

? Word “Comment” Endnote conflict???/ 

I have experienced the same problem - it appears after I insert “comments” into the document. When I remove all  “comments” I was able to format the bibliography.

Endnote X2.0.1

2008 Word 12.1.5 

I got “a COM exceptionhas occured.” on a document i was editing when I attempted to format the bibliography.  had done that before with this same file. When I removed the comments (as one user suggested) I was able to format the bibliography. The “Com exception message” is not very illustrative.

my word is 2004,for mac (Tiger, 10.4.1) and endnote is 8.

Message Edited by vmesa on 01-09-2009 04:37 PM

I’m running OSX 10.4.11 and recently upgraded to Office 2008 and Endnote X2 and experienced the EXACT same problem.  Unlike Bacitron’s attempt, I was able to get around it by doing the following:

1)  Open the document, quickly close the COM exception error window, save as RTF. Close the document.

2)  Open the RTF, save as DOC, close the document.

3)  Open the DOC and Format the Biibliography.

The comments were intact and I no longer got the error message.  I’m assuming that saving as RTF strips away all traces of the old Endnote (I used 8) and formatting with a clean .doc makes Endnote happy.

Message Edited by Manster on 01-14-2009 04:20 PM

1 Like

Same problem,  intermittend, mostly occurring to remote customers (using Win) with files generated with Word 2008 on Mac OS 10.4.11 German OR Word 2004. The files behave o.k. in both programs on my G5 (PPC). However, the error occurs also on my Mac with some files generated before the advent of EndNoteX (currently I use EndNote X2.0.1 Build 3889).

Sometimes it suffices to click ok one to three times, sometimes it doesn’t stop. It also (or only?) happens when all fields are removed (shift-cmd-F9 on Mac).

There must be some remnants of code in the Word file that are indigestible.

Developers where are you? It is not a new complaint!  

I don’t know what the developers might say, but what I can tell you is that COM exceptions happen for a variety of reasons, so there really isn’t one blanket solution to all of your issues.  They are best handled on a case-by-case basis, by either calling or emailing us here in tech support.

However, in at least a couple of the cases above, I strongly suspect that a field code cleanup might help:  You might also want to make sure that nobody is using Track Changes comments in their documents.

Switching off Track Changes does solve the problem of ungraceful crashes of Word during formatting the bibliography.

Why should one not use Track Changes comments in a document that is supposed to be free of EndNote-generated field codes? I want my fellow authors to add comments and log their changes, espesially when I give them a doc that is supposed to be free of EndNote stuff (as they don’t all have EndNote).

Your suggestion obviously implies the presence of remnants of code in the word document that is not removed by just replacing the fieldcodes with their values (ctrl-6 or in Mac Word 2008: shift-cmd-F9). Otherwise the copying of the content to a new file wouldn’t be necessary.

But it is still not clear whether EndNote or Word is to blame. … and why it happens in the first place.

Thanks for your hints anyway 

Clearing up by the method described in does indeed seem to get rid of the COM Exception error, but the instructions are not complete/accurate. The missing essential info:
It is important to NOT INCLUDE THE VERY LAST PARAGRAPH in the old document before copying. So don’t just ctl-a (cmd-a)!
Reason: The very last paragraph sign contains a lot of invisible info (which is also transferred to an rtf version). If it is corrupt one does not want to include it again in the new document!

Another question remains unanswered, though:  how to avoid corrupt code in the first place. 


I get the same error message (although the second part is in german as I use a german Word for Mac) when I do the guided tour! The error occors when inserting figures (the this case the cockatail picture). 

What  am I doing wrong?

what I use:

EndNote X2.0.1 (Bld 3889)

MS Word 2008 für Mac (Version 12.1.7)

Mac OSX (Version 10.5.5)

thanx for any help!

P.S.: Is there a way to tell Word (or EndNote) not to use the german words “Tabelle” and “Abbildung”, but the englisch terms for referencing tables and figures? (Changing the language of the document doesn’t do the trick)