help regarding the citation

Dear members,

I want to add the citation like (Tam et al. 2012a, b, c), but the end noteX7 added it as (Tam et al. 2012a; Tam et al. 2012b; Tam et al. 2012c). I have tried to resolve it but did not get the success. Please help me.

In the Style, please go to “Author Name” under “Citations.” Make sure the option “Omit repeated authors (e.g. Smith 1999, 2000)” is checked under “Consecutive Citations by the Same Author.”

Jason, Not true

 that only works if all the authors are exactly the same.  

I find that if the et al authors are at all different, it never works as one would expect.  You would need to manually hide authors, and then, it will still display each year.   

This has always been a “bug” in endnote.  

Can you suggest how to hide.

Please see our website for How to  Exclude the author or year from a citation:

If you wish to edit an in-text citation do the following:

Click in the citation in the body of the text you would like to modify. Note: With EndNote X4 or late r on the Mac, clicking on the citation may activate the hyperlink. If that is the case, hold down the [Option] key and then click on the citation to select it before following the steps below, or use the Right-Click or Control-click option.

Right-Click (or Control-click if you have a one button mouse on the Mac) on the item and choose “Edit Citation(s)…” from the popup menu. Alternatively, you can get to Edit Citation using the following method:

  • Word 2007/2010/2013/2016 with EndNote X4 and later : Go to the EndNote tab and choose “Edit & Manage Citation(s).”
  • Word 2016 Mac with EndNote X7/X8 : Go to the EndNote tab and choose “Edit & Manage Citation(s).”
  • Word 2003/2004/2008/2011 with EndNote X4 and later : Go to the “Tools” Menu and choose “EndNote > Edit & Manage Citation(s).”
  • Word 2007 With EndNote X1/X2/X3 : Go to the EndNote tab and choose “Edit Citation(s).”
  • Word 2007 with EndNote X and earlier : Go to the Add-Ins tab and choose “EndNote > Edit Citation(s).”
  • Word X/2000/2002(XP)/2003/2004/2008 with EndNote X3 and earlier: Go to the “Tools” Menu and choose “EndNote > Edit Citation(s).”
  • Pages '09 : Go to the “Edit” Menu and choose “EndNote Citations> Manage Citations…”

With EndNote X4 and later and Word 2003, 2007, 2008, ** 2010,  **2011, 2013 and 2016 , the citations will appear at the top of the Edit and Manage Citation(s) dialog box. With earlier versions of EndNote, they will appear on the left-hand side of this window. You should see the citation you selected highlighted. If it is not the citation you need, please find the correct one in the list and select it. With EndNote X5 and later , you can select Exclude Author or Exclude Year from the Formatting drop-down menu. With EndNote X4 , these options will appear as check boxes below the citation selection list. With earlier versions of EndNote, the chock boxes will appear on the right. Put a check in the box next to the option you need. Click OK. The citation should update with the author or year excluded, as you selected.

If it does not appear to be working, please check to see if this feature is disabled in your EndNote Preferences. In EndNote, go to “Edit > Preferences” (or “EndNote > Preferences” on a Mac), then go to the Formatting menu. Make sure the “Omit Author and/or Year from formatted citation if removed from temporary citation” option is checked. Click OK on Windows or Save on Mac and then close the preferences…

Instructions are incomplete there, though.  When you have a group of citations, you need to then go to “more” and can see the list of citations in the group.  You will need to know which one is (a) and leave that one alone, and hide the author from the dropdown (see attached images) for the others.  

To further complicate matters, – you can also hide both author and year, and they add a suffix to to “a” record  with something like " b, c, d" to get exactly what you are hoping for.  

Thanks you for providing the clarification there, Leanne. Yes, the settings in the Style will work only if the Author names are exactly the same in each library record.

Which is HARDLY ever the case!  will put this in suggestons forum.