How to activiate spell check properly in X4

In X4, spell check doesn’t seem to recognize most of the words–and doesn’t seem to let me add them to active dictionaries…

As in attached screenshot-2.jpg, my Spell Check Preferences options are set for American English. I have four dictionaries added to the drop-down menu (ssceam.tlx, correct.tlx, accent.tlx, and userdic.tlx); I assume that means that all four are active and used in spell check.

However, as in attached screenshot-1.jpg, when I click to spell check the title field, the program says that “music” (and all other words) are not in dictionary. When I click “add” for "music,"I am told “can’t add word to user dictionary.”

Hi, I’m sorry to say that I offer no solution. Just want to add that I have the same problem but with X3. Cannot add words to sscream or any other dictionary. /Stima

If you review the list of words in each of the four files (ssceam.tlx, correct.tlx, accent.tlx, userdic.tlx), “music” is not included so that’s why the spell check gives the impression it’s not working.  Moreover, the list of words in each of the files is very small and by no means comprehensive so you’ll need to add words to build-up the dictionaries.  (Since the dictionary file formats incorporate a .tlx extension, this precludes adding the MS Word dictionary file which is based on an entirely different .DIC file format).

Like you, I wasn’t able to add a new word to any of the four .tlx files and could do so only by changing a pre-existing word in the dictionary (not useful at all).  In checking the “Spell” folder, the setting was set to “read-only” but even after removing the setting and restarting EndNote, I still wasn’t able to add a new word.  Maybe contact tech support on the issue (link below) or maybe one of the EndNote reps patrolling the forum might help:

As a workaround I created my own dictionary (by copying and renaming one of the .tlx files). While it’s annoying to build up the word list from scratch (and pre-scanning for possible misspellings beforehand), the resulting dictionary is tailored to my specific word-use and research terminology.


Here’s a workaround to saving words in the EndNote dictionary file (.tlx)

  1. Copy whatever .tlx files you want to use  from the “Spell” folder to your desktop (for this example will use: scceam.tlx).

  2. Rename each file (for example: ssceamCopy2.tlx).

3. Copy the renamed file(s) back into the Spell Folder.

  1. Open EndNote’s Preferences, Spellcheck, Dictionaries, remove the original file (scceam.tlx) then ADD the renamed file (scceamCopy2.tlx).

  2. The renamed file now enables spell-checking and adding new words.

Also, you can incorporate Microsoft Word’s custom dictionary after all.  Just locate the file (Custom.dic), then open it in notepad, then save it as a text file.  You can then import the text file into EndNote’s dictionary.  You can also import other lists of words, they just need to be in a text file format.

Hi and thank you so much. That worked!!! Regards, Stima

I wanted to check the Help for “spell check preferences” and “modifying dictionaries” but there’s no text in the files. Anyone else have this problem?

yep, same problem here.