How to resolve "[Record #9063 is using a reference type undefined in this output style.]" in bibliograophy?

Hi there,

I’m using EndNote online for Mac, and in my end-text reference list I have two messages that have appeared beneath/above different citations:

“[Record #9063 is using a reference type undefined in this output style.]” (the second one has a different record #). I currently do not even have that number of references in my library.

How do I remove this/resolve this? I’m not sure which citations they are attached to - I’ve tried deleting/editing/re-inserting the citations either side of this message, but this message never disappears, no matter which reference I remove! I was using APA 7, so i tried changing to APA 6 which made the messages disappear, but APA 6 brought a whole lot of other formatting issues/I really should be using APA 7.

Thanks in advance!

Hi all - an update! I now realise the two messages are referring to two citations that aren’t appearing in APA 7 format as it seems that format is unable to read “Government Document” reference styles - any answers for this?

That is odd, because it appears that Government document does have a template in APA 6th that I have on my computer.  did you try to download and open a new version (from Help, Endnote Output styles)- save as to a new name and make sure that newly named style is selected in the Word document?  

did you change any of the government fields in Endnote preferences?  

Hi Leanne,

Thanks for your reply. It’s actually in APA 7th that I’m having the issues with the two Government document citations popping up with that message instead of the reference. I’ve just checked on my Endnote desktop app (I have been working from Endnote online with this particular document) and have found that Gov Document is not infact one of the pre-loaded Templates in APA 7th. Maybe I’ll just chenge them to the general “Report”… but then I’m not sure that will provide all the fields I’d like…

Or you edit it add the template and can copy and tweak the report version.  I am surprised there isn’t a “generic” that usually gets defaulted to when a template doesn’t exist?  I will download the 7th and look.

AHHH – the generic output is exactly what you were reporting in APA 7th.  So what fields in what order to you want from Gov Doc (in 6th it is exactly the same as Report -

Author. (Year). Title. (Report Number). Place Published|: Publisher| Retrieved from URL|.

but that is slightly different from 7th report

Author. (Year). Title (Report Number)|. Retrieved from Place Published: URL ).  

I had the same issue, APA 7th does not like “Generic” or “Computer Application” categories. 


Following up on this question. So, what is the solution for this then? I had the same problem when using “Government document” and “Standard” in APA 7th Ed 

This is the error message: 

[Record #625 is using a reference type undefined in this output style.]

Thank you in advance 


To add that reference type to your bibliography template list, and copy one of the others that is close to what you want and edit it to make any necessary changes.  

Editing output style instructions are here in the Knowledgebase: