Importing a bibliography in Excel as a tab-delimited file into EndNote X7


I am having trouble importing a tab-delimited file into EndNote. I am trying to import a bibliography that is in Excel to EndNote. I have watched a video and read the discussion board.  I think I have the data formatted correctly but apparently not because I keep  receiving the following error:

Tab Delimited Import Error:

Bad Field for this Reference Type – Author

I have checked my Field Names and they seem to match up with EndNote (X7). I have removed the “and” and have separated author names with //

I have experimented with both using  *Journal Article and not specifying the reference type in Column A and using *Generic and having Column A = Reference Type and specifiying Journal Article in each row (I am only importing journal articles).

I have removed all "

I have attached my tab-delimited Text file as an example. The sample contains 2 journal article records which are separated by a paragraph mark.

I would really appreciate help on this–Thank you!!!

Kind regards,

Test records to import to EN.txt (6.1 KB)

Based on your text file it seems two corrections are needed: 1) delete an extra space appearing after some of the column/field names; and 2) replace the double-slash marks with a semicolon; also include a semicolon after the last author. (Refer to attached image #1.) Also note the format of your author names should be in the “last name-comma-space-first name” order. Your author names are missing the comma which becomes problematic after importing, and more so if writing specifications require having a comma.)

Once the corrections are made your text file imported successfully into Endnote (refer to attached image #2).

Thank you very much! I will try this tomorrow.

I was wondering about the authors missing the commas. I need to look into that. I was given an EN library to work with that had annotations that  that I needed to combine with an updated bibliography and so there has been a lot of back and forth between Excel and EN.I am afraid that happened during my export from EN to Excel.


It might be possible to make some adjustments concerning the author names depending upon if 1) the data  being imported from Endnote, or to 2) if the data is in Excel (to be imported into Endnote).

If the data is in Endnote you could adjust the author names before exporting from Endnote into Excel by changing the Author Names setting in the output style file so the first- and co-authors are listed in “last name, first name” order. You could also modified the Authors Lists setting to place semicolons between authors. Both adjustments should save you some time from having to correct the exported data as it appears in Excel.

If the data is in Excel it might be possible to use some of Excel’s features to separate the author’s last name from the first name or initial, insert a comma between last name and first name, and insert spaces and periods for initials. But this  would depend on how the data has been laid-out. Would need to see how the author names have been set up in the Excel spreadsheet to get a better sense of things.

At the end of the day, Endnote should be able to handle most authors imported as GN SN without commas?  The ones that would give it trouble are those with double barrel names, or multi part names, like Machteld van der Feltz.  

– ooops never mind.  I see the problem – they are SN GN initials.  – There might be an import setting to fix that?  --It would also be easier if the initials should also be separated by a space.  – In fact the RefMan RIS filter is set to Last Always Precedes First.  

Thank you again! Removing the extra spaces worked perfectly.  In my test sample,I did not change the // to ; and it still worked fine. I read that you can use either ; or //. Can you explain why you prefer the;?

I see what your talking about regarding the authors. I wish I would have known that before!  I re-exported the original library with the changed author settings and it worked well (including separating multiple authors with  the semicolon.)


@lskalla wrote:

…Can you explain why you prefer the;?


Thanks for the update. Using semicilons as delimiters is just a longstanding personal preference. Might might use a slash on occasion to facilitate manipulating data or fields.