Initials appearing some citations

I am using EndNote x3 for my dissertation.  A few of my citations are picking up the initials of the authors.  It appears to be two that this happens with and they also have other articles which I have cited.  I cannot manually remove them without them returning.  I have tried to update the names in the library of EndNote and it returns.  Can you advise.

Make certain that all author names are consistently entered into your EndNote library, including spacing and punctuation. For example, if you have entered “Smith, J” as an author in one record, you need to make sure every other instance of that author’s name in that library is identically formatted. Please note that a difference as small as one space may cause EndNote to believe it is dealing with two separate authors and add the initials.

It sounds like you may have already tried that, by updating the library entries, although if it is a spelling change in the surname itself, it might not work, due to the travelling library, at least in X3 and earlier versions. The travelling library can result in the formating “ignoring” the corrected record in the library, in favor of the one in the travelling library.  The easiest way to get rid of that is to unformat the refs in the document to the endnote temporary citations and then to reformat them. 

Initials are used to distinguish authors from each other when they have the same last name. So you might first check if this is the case.

But if you prefer and the style guidelines for your discipline indicates omitting initials is acceptable, you can change the option within the output style’s Citation “Author Name” section:

  1. Go to the toolbar, select Edit > Output Styles > Edit [name of the style you’re using].

  2. In the output style’s dialog box, locate “Citations” section. then click “Author Name”. Then on the right-side, deselect the option: Use initials only for primary authors with the same last name.

  3. Close the output style to save the changes. Note that this will be saved as a new output style with the word “Copy” added to the file name so adjust EndNote/MS Word to use the new style.