Linux related questions

Dear Ieragadu, Dear Ulrich,

please read my last post concerning EN X5 (full version) and Ubuntu 11.04 and Word 2007 pro. On other part and according to P. Travis and my previous posts, the CWYW (Oxt extension) is a windows extension  and cannot be inserted in O.O. or L.O. in Linux distros.

CWYW can be inserted in  MS Word 2007 pro but it doesn ´t work correctly (My last post). Word has its own riched.dll.

Fedora 15 has the tahoma in wine as package and winetricks too. With these new distros (e.g. Fedora 15 and Ubuntu 11.04, one misses still the texts in EN X5  My  library (All refs, unfiled, trash  aso…). EN X2 only  inserted the texts in My library correctly.

Can you test the new Ubuntu 11.04 with your demo EN X5 as described in your post.

Thank you in advance


Dear Ieragadu, Dear Ulrich,

concerning my answer and Fedora 15, I join a screenshot about  Wine/Tahoma fonts for F15

Best regards



As I’d screwed up my Linux partition (duh!), I just had to install evrything anew from scratch – and EndNote no longer works as previously posted :-( 

Gotta fiddle around again (no idea what I’d done right before, solely the inclusion of riched20.dll and Tahoma font appears not to be the answer: text no longer shows up in the edit window, neither in English, German, nor Japanese).

(In your case, maybe installing MS Office added something EndNote needed – but for me, that’s not an option.)

Pity, it DID work on my previous installation (CWYW I can do without, actually – I use EndNote since the early nienties  (DOS version 1.2)  to manage all my reference collections … well, the CWYWSA [SA = StandAlone] Peter Travis gave me once was actually a nice workaround for EndNote X1, but sadly failed me in later EndNote versions – and Peter’s out of Linux now, as he states above).

So, sorry, can’t help you with Ubuntu 11.04: as all my other BioScience programs run nicely on Ubuntu 10.04, I won’t update until the next LTS version comes along.

Will let you know if I get this back to work,


(Ieragadu is just my screen name – and my mother tongue actually the same as yours, but I run my laptop in Englisch, since most bioscience programs are in this language)

Trying to get a new EndNote X5 [Demo] version to run on my freshly re-installed Ubuntu 10.04 LTS failed miserably despite using the newest wine 1.3 version plus winetricks (both from PPA repository) which had worked just fine in the previous install (except CWYW). Trying all sorts of winetricks, overrides, fonts – nothing worked, either the groups didn’t show, German umlauts or Japanese kanji would not display, or the preview window showed either garbage or stayed empty altogether.

So I did a “complete removal” uninstall of all things wine-related, removed the PPA repository from the settings list, and then re-installed the wine version associated with this Ubuntu LTS-version, wine 1.2.2, incl. wine gecko.

Then, as this had shown to help in my previously working setup, I then enabled (in the Wine Configuration window, Default Settings: Windows XP) both riched20 and riched32 as (native, builtin) overrides, and copied the Tahoma font from my Windows installation in VirtualBox to the existing (empty) Fonts folder in ._wine/drive_c/window_s.

Installation of EndNote X5 then went smoothly, and foreign characters showed up correctly in the main, preview, and edit windows after changing the fonts (Edit => Preferences => Display Fonts) both for library and General from Arial to Tahoma. Editing, importing, connecting to EndNote Web all went smoothly (till now), not yet checked the new PDF-feature and Libreoffice.

Dear Ulrich,

thank you very much for your answer and comments. At first some details about my activities concerning Linux and EN versions.

I tested EN 1.2 and bought it in the past (Cherwell Cy/Germany) (Screeshot 1). I tested and used all the commercial versions ( 1,2 to X5). A review of the EN 4 was published in Laborpraxis and a review of the EN 8.01 in the Adeptscience ( Frankfurt) homepage (see presse) and a review of the ENX4 will be published in september  (these reviews are in German language).

I used and use 2 computers for linux distris testings (I am linux beta tester) (Optiplex Dell SX270 and SX 280 (3,2 GHz) and 1GB RAM)  and 1 computer Optiplex GX620 Pentium DualCore and 4GB  for Vista Ultimate and Win 7 Pro/ Word 2007 and a laptop latitude E5500 with 4GB RAM /Win 7 Pro and Word 2010 pro plus.

After my retirement from the University of Freiburg (Germany), I have a lot of time to test and help the members of the community for troubles  concerning Linux or Windows EN installations and uses.

At this time, I didn’t need help for Ubu 11.04 and EN X5 but FEEDBACK of other members concerning Word 2007 and Word 2010 CWYW ENX5 insertion and linux distris used.

The insertion In Office  occured e.g. occurs with new linux distris like MAGEIA 1 (Fork of Mandriva) and MOON OS 4 Beta (Basis Ubu 11.04).

I wish you a succesful research and a nice day.

Best Regards



Hello Jean-René,

thanks for your reply (this entre-nous conversation apparently proving that not that many peolpe use EndNote on Linux – or maybe they’re so computer savvy [which I am not] that they have no problems with it). Your 1.2 floppy picture sure brought back memories – I’d bought mine (from the same source) for Berlin’s Burn Unit (“Zentrum für Brandverletzte”), and, as I was the only one using it, eventually got to keep it when the unit was closed, for subsequent use on my OS/2 system. My present EndNote X5 (legalized from demo recently, as it seems to work fine on Linux) runs under Ubuntu 10.04 LTS with wine 1.2.2 on a ThinkPad Z61p (Core2 CPU T7400@2.16 GHz, 2.0 GB RAM.

As to your feedback request, I have nothing to contribute, sorry – never used MS-Office. But, as you say you are a Linux beta tester, I have a question, if you please: did you ever get to test Peter Travis’ [alpha] CWYW-SA EndNote plugin under Linux, on an EndNote version later than X1? There this Java applet worked just fine (,,) but I did not manage in X3 – and now in X5, there’s no Data Visualization option anymore, so that’s history (pity, that, I liked RefViz visualisation [2.1]).

Greetings from the Capital to your beautiful region (9 school years spent in nearby Salem),



Hello Ulrich,

many thanks for the reply to my message and for the URL as jpg joined in it. Have you contacted Peter in the past in order to receive the java applet (CWYW stand alone). it is for me a new thing and I should be very pleased to receive it and test it with EN X2 and higher. I hope that Peter (Peter Travis) will read this message.

On other part, I test PENA OS Version 0.8 (Basis Ubuntu 10.04 LTS) . This version has Firefox with Zotero as add-in . PENA OS  was compiled for scientific people (see google Pena OS ) using EN and Zotero.

It looks (Desktop) like XP/ Vista) and it is very amazing to work with it. German display and keyboard support is very good.

I installed Word 2007 pro plus via Wine and EN X5 problemless. ( Text in EN X5 library  disappears as previous described. CWYW extension can be seen in Word.

When EN X2 was installed, the various texts were displayed in the EN X2 library. I test Wine versus CrossOver  and EN X2 at this time. New message in due course. 

I used OS/2 in the past and a  OS/2  Schell compiled for Win 3.11. It was very amazing to work with it.

Greetings from Schallstadt to the Capital (The Capital is very beautiful too)


Dear Friends 
I have installed MS Office 2007 through PLAYONLINUX ON UBUNTU 11.04 - 64BIT PC which is working flawlessly except that the file associations are not working. 

I also installed Endnote X4 according to the method given here (

I can see two problems: 
First, endnote plugin is not visible in MS word so CITE WHILE YOU WRITE is not working 

Second, endnote is not showing my group folders properly ( only icons, no names !! ) in my endnote library. 

Any suggestions??? 

Dear Yaten2020,

concerning your problems :

_ I can see two problems:  _
_ First, endnote plugin is not visible in MS word so CITE WHILE YOU WRITE is not working  _

Second, endnote is not showing my group folders properly ( only icons, no names !! ) in my endnote library.

please note that the CWYW  extension of EN X4 doesn´t appear in MS because it is a windows programmed extension.

At this time (see TRENSOFTY messages) the CWYW extension appears ONLY with EN X5 in MS 2007. Why? TR and I don´t know!!

On other part (See my messages) no names are appearing in EN library. Only with EN X2 . Why? TR and I don´t know.

I tested a lot of distris (e.g.  PENA OS, Manhattan OS, MACBUNTU OS, MAGEIA  a.s.o…) . The same appears with EN X5 or EN X2 and MS 2007. Wine versions : 1.1.1 to 1.3.29  or CrossOver for Linux.

Best Regards


Make certain that you have also set EndNote’s General Display font to a Unicode font.

There are two display font settings in the EndNote preferences. The Library Display Font determines what you will see in the library window. The General Display Font determines what you will see inside a record, in the preview window or inside an output style, filter or connection file.

Dear Henry LJ,

thank you very much for your answer and comments. I used last year the general and library display  and small size (from 12 pts to 8,6) and arial unicode. I saw the same picture with various distris  (see my attachment ) and various EN versions.

ONLY EN X2 shows the texts in the library window.

Please tell me :

  • What a kind of linux distro are you using!

  • Have you used ARIAL Unicode ? 

  • Please send me a screenshot (analog to my attachment with your settings)

Thank you in advance for your answer and help.

Best Regards


Hi Folks,

I am running Ubuntu 14.04 64bit and have EndNote 7.1 installed on Windows 7 64 bit which runs in a virtual machine.

I also have office 2007 installed (running on the same Windows installation in the virtual machine).

Everything works except syncing my references with EndNote Web.

I can manually import and export references to and from EndNote Web, but using the sync feature in EndNote does not seem to do anything.

When I click sync, EndNote appears to sync.  I am not given any type of error message.  It is only when I check EndNote Web that I see that in fact, nothing was synced.

Has anyone else had this problem and if so how did you solve it?

Thank you very much, EndNote is great and makes writing my thesis much easier.  It would be fantastic if I could get the sync feature to work.