Linux related questions

To help organize the forum this thread this topic has been given it’s own thread.  Important information to keep in mind when reading this thread:

  1. There is no Linux version of EndNote, there are only Macintosh and Windows versions.

  2. While it is possible to run EndNote on Linux using WINE, this is not a supported way to run EndNote and Thomson Reuters will not be able to provide technical support.

  3. You will not be able to use Cite While You Write with Open Office.

That said, here are the steps I used to install EndNote X2 for Windows on Ubuntu 8.04:

While there is no Linux native version of EndNote, it is possible to run EndNote X2 using the latest version of Wine.  Note that running EndNote on Linux is not supported and there are some compatibility issues, Unicode characters for example will not be displayed.  That said, these are the steps I used to install EndNote X2 on Ubuntu:

Installing Wine:

You will need a recent version of Wine to install EndNote X2 on Linux.  Most distributions do not have the latest versions of Wine available as a package.  These steps will make sure that you have one of the latest versions available.  If you already have wine version 1.0.0 or higher you can skip to the Installing EndNote X2 section.

  1. Go to “Applications > Accessories > Terminal”


  1. Enter the following to download and install Wine: (see )

    wget -q -O- | sudo apt-key add -

    sudo wget -O /etc/apt/sources.list.d/winehq.list

    sudo apt-get update

  2. If you already had a version of Wine installed do the following:

    sudo apt-get remove wine

  3. Enter the following to continue the install:

    sudo apt-get install wine

  4. Configure Wine to use Windows 2000, enter the following to configure Wine:


  Wine config

  1. Verify Wine:

    wine --version

  wine version

 You should see version wine-1.1.6 or higher

  1. This part is optional, but recommended.  There is a bug in Wine that will cause EndNote to crash when you highlight text, this step will resolve the issue.  You can view the bug report here ( ) .  There is a script by Dan Kegel that will resolve the issue ( ) .  In the terminal window you would need to enter the following:

    sudo apt-get install cabextract


    chmod +x winetricks

    ./winetricks riched20 riched30

Installing EndNote X2 from the Windows CD:

Once Wine has been installed, the installation of EndNote is not that different than installing it on a Windows computer.  You use Wine to run the Setup.exe installer.

  1. Insert the CD

  2. Go to “Applications > Accessories > Terminal”


  1. Change the directory to your CD drive, on my machine that was /media/cdrom0

    cd /media/cdrom0

  2. Run the installer:

    wine Setup.exe

  3. If you would like an EndNote shortcut/launcher on your desktop, then you can use the following to copy the icon.  Note that you would need to change /media/cdrom0 to your CD drive if it is not cdrom0, you would also change “Program Files” if you are on a non-English system, i.e. “C:\Programme\EndNote X2”:

    cp /media/cdrom0/autorun.ico “wine winepath -u "C:\Program Files\EndNote X2"

  4. Test EndNote:

    wine “C:\Program Files\EndNote X2\EndNote.exe”

  getting started

  1. Click on “Open an existing library” and navigate to “C:\Windows\Profiles\All Users\Documents\EndNote\Examples\Sample_Library.enl”

Message Edited by PTravis on 12-04-2008 08:43 AM



Thanks for the detailed instructions.  One of my colleagues uses EndNote under wine, but it is nice to have the ‘how-to’ in any case.

Using MS Word+EndNote under VMWare Server seems like the best solution now, given known limitations of EndNote on Wine & given that openoffice compatibility has not yet been implemented.  But, this might be useful for when I just need to edit my library & I am eager to try it.

Thanks for the clear instructions; I discovered the reason EndNote was crashing even more than the Windows version on Ubuntu 8.10 was two rogue és in my library. I had to export the library to an .end file, delete them in a text editor and then re-import to a clean library, which now works fine.

Of course, I’m now about to ask about CWYW in Word under Wine… having trouble installing it manually as I can’t register the EndNote Cwyw.dll without incurring an ‘incorrect access of C library’ runtime error. Has anyone been successful in this regard?

There has also been some work on this through CrossOver: CrossOver Forum Discussion

You can install Endnote in a CrossOver bottle, but just as with Wine, CWYW doesn’t work…

Message Edited by lackscr8ivity on 11-14-2008 04:58 PM

Not being able to register the DLL causes CWYW to fail, so I’ve been writing these papers using temporary citations. What a surprise - the lack of unicode support corrupts the output of most styles, inserting “Ã,Å°” in their syntax which is immediately replaced with more junk if you try and edit the style. Result: (unusable streams of gibberish, 2008). Bibliography similarly affected. EndNote on wine appears to be only good for the “middle” bit of a project: to start and finish it properly you still need windows.

Having a mirrored library at EndNoteWeb, surely that will help… nope, the citations need to be different. Guess I’m spending the early hours of this morning on campus doing Endnote maintenance before the deadline.


Your post was the only one I could find that referenced running EndNote under VMWare server.  I’m having trouble installing EN.  I get:  Error 1606 Could not access network location “.host\Shared Folders\Pictures” and yes, that folder exists.

Any advice?


Hello unattach,

Is the problem specifically when you are editing an output style and trying to add Unicode to the templates?  I am able to format references containing Unicode when using the Tools > Format Paper" command, see attached screenshot.


I’m pleased that there does, after all,  seem to be some consideration at Thomson Reuters for scientists running their computers on operating systems other than Windows and Mac, and who, like me, would like to stick with their longtime EndNote libraries. 

The installation instructions for EndNote with wine in this thread, and previously a personal one from Peter Travis (in reply to my post “Linux Version / OpenOffice compatibility” in the “EndNote Product Suggestions” thread – thanks again, Peter!)  were extremely helpful in setting up a [nearly] fully functioning EndNote installation on Ubuntu 8.10 with wine 1.1.19 emulating Windows XP (works now).

This includes a great little [java] tool I was sent as beta-tester version called CWYWSA (“Cite While You Write Stand Alone”) to integrate with Open Office (here: native Ubuntu version via rtf-formatting. This works just fine, at least with the smaller test databases I’ve run thus far.

There’s two issues here, however, which have prevented me from finally ditching my Windows partition altogether:

One, that CWYWSA lists ALL references per library, making all my numerous CUSTOM libraries irrelevant – but that’s not that much of a problem, as I just copy the referencess I want to use in a paper into a separate library (something I’ve been doing over the years anyway), and just run that.

More serious, however, is the display font coding problem I encounter: many of my reference titles are in German, French, or Japanese – Unicode support is the number one reason I switched back to EndNote from Reference Manager required at work, which still doesn’t have it.

This works great in all imports, everything shows up correctly in CWYWSA, and subsequently in my final Open Office Writer document! Not, however, in EndNote itself, anywhere…

In order to show titles correctly in the main library window, I tried to change the corresponding display font to Kochi, Sazanami, or MS Gothic/Mincho [Edit => Preferences => Display Fonts => Library]. All these resulted in the correct display of Japanese author names and reference titles, but not German or French special characters. Other fonts, no Japanese. And nothing at all helped in the individual reference preview or edit windows: garbage only, including the final “Tools:Format Paper” step in EndNote (the resulting formatted paper in OOo-Writer, however, correct as mentioned).

As both CWYWSA and Open Office run under Ubuntu native, with no display issues at all, the problem seems to be with EndNote and wine. I tried fiddling around with various font-related suggestions found via you-know-which search engine, wine-locale and such, but at best did not mess up my whole system.

While this problem does not impair the functionality of importing references into EndNote and subsequently using them in Open Office documents, it severely hampers any efforts in organizing references – and editing is tedious: Western special characters (using Arial font) are accepted, but not displayed other than in the main window. 

Anybody out there with greater insights into wine have any ideas how to fix this?


Message Edited by Ieragadu on 2009-04-22 12:48 PM

1 Like

It sounds from your post that:

a) you can run Endnote X2 under Intrepid and Wine

b) you can CWYW using OpenOffice.

This is quite amazing.

I am running CrossOver Linux, the not-free version of WINE.

Would you mind detailing exactly how you got Endnote X2 to run?

And are you at liberty to share the stand alone CWYWSA along with any installation instructions?

being able to run Endnote would allow be to (almost) junk XP invirtualBox .


Hello jmarks,

> It sounds from your post that:

> a) you can run Endnote X2 under Intrepid and Wine

  • well, EndNote X1.0.1 actually, but yes, it does run fine, thanks to the installation help from Peter Travis (who assured me that, as far as it concerns Linux integration, there’s no difference between X1 and X2). 

> b) you can CWYW using OpenOffice.

  • that indeed is nice, but somehow still in a testing stage, as I haven’t heard about this feature other than from Peter… Only problem I’m having with it thus far is I sometimes have to restart EndNote after having added new references, because CWYWSA does not start then (Data Visualization grayed out).

> This is quite amazing.

  • yep, I’ve been trying this in vain for a couple of years, but now it seems we’re getting somewhere … 

> I am running CrossOver Linux, the not-free version of WINE.

  • no idea about that, never tested it, sorry …

> Would you mind detailing exactly how you got Endnote X2 to run?

  • sure,  just I don’t want to clog this thread – Peter has detailed it pretty much already (except that, in newer wine versions, there’s no need anymore to fall back on Windows 2000, all icons install nicely in their proper location, and I haven’t [yet] seen EndNote crash when highlighting). If that’s not enough, ask me again directly at

> And are you at liberty to share the stand alone CWYWSA along with any installation instructions?

  • that I don’t know – I was sent this file as beta tester [more precisely: alpha version],  back in May 2008 without being told what I’m allowed to pass on – maybe you try to contact Peter yourself? 

In general terms, it’s a Sunacle Java applet running under EndNote as Data Visualization tool (which is why I haven’t tested it in my VirtualBox-Windows XP, as there I have RefViz installed for visualization). 

It puts all references from a library into a list, from which you can select the references to be cited (single/bulk), use additional boxes to exclude author or year, cite with the author outside the parentheses as Author (Year), add prefix [eg: see also …], or add suffix [eg: …, p.10]. Then you Update to the selection box, copy CTRL+C, and paste CTRL+V as temporary citation at the desired location in your (Ubuntu!) Open Office document. 

When you’re done with the paper, save it in .rtf format. Then, back in EndNote, you load it with Tools - Format Paper, select the output style, and when you then press the Format button, a new .rtf version of the paper (with style information added to its name) will  be saved. <check screenshot attachment>  

A bit more tedious than with Word, maybe, but it beats typing. Problems may be having to stick with .rtf format (not all my .odt files with tables and graphs convert correctly). 

My main problem is, as stated, special characters, be it Western or Asian. Good news is, all such characters are apparently retained when imported, and as such are carried over into my documents (Japanese, for those who know what I’m talking about here, I use Ubuntu’s SCIM-anthy to edit a RIS-formatted (template) file in UTF-8, then import into EndNote library as text file with RIS filter). 

Bad news, that in EndNote itself, it’s a matter of flying blind, as these characters are not displayed correctly in the edit or preview windows, and in the main library window I have to adjust the font preference for either Western or Asian).  Why this is so, no idea, as under Windows, all works fine with Arial font selected – but I’m a biologist, not computer scientist. 

> being able to run Endnote would allow me to (almost) junk XP invirtualBox .

  • if you can do without special characters (umlauts, accents), you should be able to … provided you can get your hands on a CWYWSA copy. 


=== ADDENDUM: Ubuntu 9.04/wine 1.1.20 & VL PGothic font ===

Updated Ubuntu to version 9.04, wine 1.1.20. EndNote X1.01 runs as before – i.e. Unicode is handled, but not displayed other than in the main library window. However, I no longer need to switch between Western and Asian fonts here after installing the VL PGothic font, which displays both umlauts and accents, as well as Kana and Kanji  (pretty ugly, but at least I can see what I’m dealing with) <see second attachment>

Message Edited by Ieragadu on 2009-04-27 12:22 PM


I have been using Endnote 6 under linux with wine for two years and it works perfectly (no display problem, even for French characters such as ç and é or German ones such as ß or Ü). However, I am getting more and more references with author names comprising unusual characters that are not handled by Endnote 6 ( such as Š and č) and it is becoming impractical to edit them manually in all bibliographic outputs, so I am considering moving to a newer version of Endnote that supports Unicode. And here is my problem: I tried today installing Endnote 9, the install went fine and the special characters are displayed well within the upper window (the one with the list of bibliographical references), but are totally wrong in the lower one (the one with the formatted output) and in the window that opens when I double-click on one citation to open it (for instance, “génétique” becomes “génétique”) . I have this feeling that this problem should be easily solved, since the Unicode display looks fine in one window out of three! However, even after spending my day on it I could not find any way to fix it. I know that some other users on the forum experienced a similar problem: has any solution been found since then?

Hi everybody,

I just have installed X4 on my box (Wine 1.1.29, OpenSUSE 11.0, KDE 3.5.9).

I do not see group names (window “My Library” on the left side). Other things (reference window; preview, search & quick edit tabs; menus) look ok. I did not have such a problem with my previous X3.

Can somebody confirm similar behavior? Or maybe somebody from Reuters could comment on it…?

With best regards, Kris

Kristof M. Lebecki, Dr,
  Fachbereich Physik
  Postfach 674
  Universitat Konstanz
  D-78457 Konstanz, Germany
voice: +49 (0)7531 88 - 3796
  fax: +49 (0)7531 88 - 5325

I found this on the Endnote FAQs page, but I’m unfamiliar with Linux, so not sure if it will help.

Interface 16: With EndNote X3.0.1 or later, my group icons have disappeared. How can I fix this?

Answer: This will happen if your "Library" font size is set to below 10 point.

To fix this, you will need to go to the Edit menu and choose "Preferences". Here, go to the "Display Fonts" section on the left, and choose the "Library" tab. Click the "Change Font" button and make the size at least 10 point.


> Interface 16: With EndNote X3.0.1 or later, my group icons have disappeared. How can I fix this?

> Answer: This will happen if your “Library” font size is set to below 10 point.

No, that did not help. First, as I said X3 worked fine. Second, my “Library” font size is set to 10 point, so according to this statemet I should not have any problems. And I do not have any problems on my MS Win box - problems appear when using with Wine+Linux.

First of all I am anyhow interested: can anybody confirm it?

Updated: I attach screenshots for X4 (build 4845) and X3 (build 4094)


Hi there,

same problem with X4 not showing the group names under wine (but I had that with X3 also -see attachment-, surprised you did not?)

Moreover, the coding problem persists: all is ok in the main window, but not in the lower display window, or the edit window.

That really sucks, even though (as pointed out rather verbosely before) the unicode characters are retained intact when exporting to OpenOffice Writer – they’re just not shown in EndNote, which really hinders productive work.

Thus, I run EndNote not in wine, but in VirtualBox, with Windows 7. Works great, but EndNote being the only Windows program I still use, that’s quite a memory hog for just one program :frowning:

I’m getting sick of this Windows tie-in, and am therefore looking into Mendeley – check it out!


OK, so I’m not giving up after all on trying to get EndNote, which I use for more than 20 years now, to work on Linux:

!. Operating system Ubuntu 10.04 Lucid Lynx (didn’t upgrade to 10.10, as I prefer the LTS versions).

  1. Installed the latest _ wine version 1.3.10 _, and while I was at it, also winetricks and PlayOnLinux, all from the repository, set it to Windows XP in the Applications setting of wine configuration (Ubuntu, Applications menu).

  2. included the Riched20.dll from my old Windows XP installation, marked it as Override (native) in the Libraries section of the wine configuration (Applications menu)

  3. Installed my _ EndNote X3 _ using “Wine Uninstall Software” [?] (have not seen a need for X4 yet) –  no problems during instalation

  4. Opened the  sample-library in the Examples folder: lo and behold, for the first time did the _ Groups _ navigation show up correctly under Linux!

  5. The foreign characters, however, were not displayed correctly, as before – but this time, I could hardly believe it, simply changing the display fonts in EndNote ( Edit => Prefrences => Display Fonts) for both Library and _ General _ from Arial to _ Tahoma _ (12 pt) did the trick! (see screenshot – Japanese characters looked nicer with TakaoPMincho, but Western characters did not – no idea where that font suddenly came from – nor Tahoma, for that matter)

  6. Editing a new reference worked fine, mixing both German and Japanese, nothing changed after saving (as always had in previous failed attempts) – see the 2011 -entry in the TEST Foreign Titles group

To Do:

  1. Test with some of my large libraries still residing in the VirtualBox-Windows7-environment – if successful, I can happily do away with that and free a lot of disk space and memory …

  2. Test with a demo version of EndNpote X4 …

  3. Get EndNote to work with LibreOffice 3 – that ( RC2 ) installed without problems and runs just fine, both native and under wine, where I’d installed it to test the OpenOffice-CWYW (which seems to work fine in the Windows environment). Under wine, however, I did not get this extension to run (found in the Product-Support folder of EndNote under CWYW).  It installed allright, showed up inthe menu and as a separate bar, but always gave an error message when activating any of the buttons, even if both programs were running.  So I might get back to testing the CWYW-SA (Standalone) beta based on Java that Peter Travis (he of the OP)  once kindly let me test for X1, where it worked just fine (but the foreign character and group displays at the time did not)  

So, it looks as, in general, I’m finally getting somewhere with EndNote on Linux – hoping for the best, and

a great New Year 2011 (of the Rabbit) to all

[UPDATE 2011-01-26]

Due to a system crash, I had to re-install everything from scratch – regarding EndNote and wine [forgot to mention: 1.3 is from the ppa launchpad], I did exactly as described above – and it worked as before, so no magic there :slight_smile:

Just still can’t get CWYW to work with LibreOffice – and CWYWSA (CWYW standalone) does not seem to work with EN X3 :-( 

Dear Peter,

I found your message very interstig and it corroborates my own experience concerning Linux and EN Versions.

Can you read my last messages and give me any comments (p.e  when texts disappear with the last versions (EN X3 and X4)

Thank you in advance 


Unfortunately I am not able to add to the topic, the community is able to provide more useful information at this point.  The original information I had came primarily from my experiences on my home machines running Linux.  After ten+ years of using Linux on my home machines I have stopped using Linux and transitioned to Mac OSX.

Dear Peter,

thank you very much for the fast answer. I hope that the community will be able to answer  and to provide anything concerning new  Linux Distros and new EN versions (e.g. EN X3 or X4). The messages concerning Linux are rather old.

Best regards


Short note:

just installed the new X5 Demo version on my Linux (Ubuntu 10.04-LTS)  system, using wine (1.3.24, set to emulate Windows XP_) and winetricks (20110629, used to install r_iched20.dll, set to native, plus Tahoma font,  for showing/editing foreign fonts correctly).

Seems to work fine thus far (see screenshot), and no problems connecting to EndNote Web – just still have not figured out how to integrate the plugin to Open (Libre) Office, neither Linux-native nor Windows-wine :-(.

Any hints welcome,