Macintosh 21.2 update problems


I’ve tried to update my current Endnote (Macintosh) from 21.1 to 21.2 today, and each time I’ve got this message saying it couldn’t find my copy of Endnote, which I know is in my applications folder where it should be. This is the second time it has happened as I also had problems updating from 21.0.1 to 21.1. I’ve tried downloading the manual update and the same thing has happened as the automatic update.

1 Like

You may try to directly install the latest EndNote 21.2 update by re-installing using the latest EndNote 21 installer, which can be obtained from their official support website below:

The caveat of this alternative is that you will need to re-enter your EndNote 21 license details during the “upgrade” or installation process.

You can proceed to install even without uninstalling the EndNote 21 application. Rest assured, your existing EndNote library data and settings will remain intact. Make sure you have your EndNote 21 Product Key ready, and a Serial Number of your previous EndNote license if you have purchased the EndNote 21 upgrade license.

Download the installer for EndNote 21 for Mac, and quit your EndNote 21 and Microsoft Word applications. Run the installer, and allow the installer to continue by inputting your device’s password.

You will see a prompt by the installer saying something like:

“Would you like to overwrite the EndNote 21 at /AppIications/EndNote 21?
You are about to install EndNote 21 version, but version is already installed. This cannot be undone.”

Click “Yes”, and follow the on-screen prompts and finish the installation.

Afterwards, you may open EndNote 21 and click on the “EndNote 21” menu > “About EndNote 21” to check if the latest update has indeed been installed.

I’m having this issue too

Thank you Faaiz for this, although I should note that this is what I did for the last update (21.0.1 to 21.1) - Endnote customer service provided me with a link and licence details. I didn’t think I would have to do it again. I will try the download from your link here and it should work.

1 Like

I also get this message that no copies to update could be found.
I just went through a whole reinstalling process to get 21.1 last week, and I don’t want to have to do it all over again…very time consuming.

In my case, the update succeeded, but it deleted all of my saved searches. Not good.