Not importing duplicates when importing PDFs (auto PDF deduplication)

I sometimes have others (RAs, Admins) fetch article PDFs for me and import them into my EN 20 database when deadlines loom which has lead to the creation of A LOT of duplicate entries. Isn’t there some way that EN could automatically check if a reference already exists in a database BEFORE it creates a new record? Alternately, create the new record then AUTOMATICALLY do a “find duplicates” and remove it again/ask user how to proceed (i.e., which record to keep).
I’m pretty sure it still does this automatically when importing RIS files, and I know you can manually run “Find Duplicates,” so the scripting exists, so why can’t this be done when importing PDFs as well?

  • From the “similar topics” suggestions, I realize that this has been an issue since at least 2015, but am re-posting to bring it back to the the attention of Clairvate.*
1 Like

When you import PDFs into EndNote there is an option to “Import All” or “Discard Duplicates”. You might want to see what setting is being used for the imports.

Thanks for the suggestion. I just checked this and for individual file imports (File → Import → File) it is set to discard duplicates.
In my case, the RAs drop the PDFs into an Auto-Import folder I’ve set up (Edit → Preferences → PDF Handling, PDF Auto-Import Folder) thinking it would simplify things. It seems like Auto-Import PDFs doesn’t follow the discard duplicates setting set above.
I guess I could turn off the Auto Import and import the whole folder manually (first point) and see if that works. Either that or get an RA to remove the duplicates manually.

UPDATE: I just tried turning off AutoImport Folder and importing a folder manually using File → Import → Folder and it kind of worked. EN still imported the actual PDF, it just added it to the existing citation rather than creating a whole new entry. So I guess this is a 50/50 fix. :person_shrugging: