*optional* field in bibliography

The journal formatting I need to use requires that the pages be preceded by p. or pp. in the bibliography. So I inserted that in the article reference type. However not all articles have page numbers (e.g. forthcoming papers). How do I make the p. or pp. optional, so that they will not show for those entries which do not have page numbers?

If no page numbers are provided in the reference type then none will appear in the bibliography providing the output style’s template was set up to reflect this. Have you tried to make a sample entry without page numbers and checked the corresponding bibliographic format? 

This is how the entry looks like:

Author ([Year]): ‘Title’, Review of Reviewed Item; Journal|, Volume|(Issue)|, pp. Pages|.

So what do I need to do in order to solve the above question? Write two reference types for Journal Article, one with and one without page numbers? Is that what you’re saying?

BTW, what are the strokes (’|’) for in the entry? What is it about ‘Review of …’ etc that let’s it appear only for relevant entries and not for others? 

@suspekt wrote:

This is how the entry looks like:

 

Author ([Year]): ‘Title’, Review of Reviewed Item; Journal|, Volume|(Issue)|, pp. Pages|.

 

So what do I need to do in order to solve the above question? Write two reference types for Journal Article, one with and one without page numbers? Is that what you’re saying?

 

BTW, what are the strokes (’|’) for in the entry? What is it about ‘Review of …’ etc that let’s it appear only for relevant entries and not for others? 

EndNote uses assorted “codes” in the output style template to string the individual parts of a reference (e.g., Author, Year, Title, etc.) along with punctuation and special codes (e.g.,  | which is a “forced separation” that separates fields, or • which links adjacent text.

From your entry it looks like the “pp” plural field is included - so assuming your reference has page numbers, the “pp.” followed by the corresponding numbers will appear in the bibliography.  If there are no page numbers, the “pp.” should not appear in the bibliography.  However this assumes the output style’s template has been set up correctly so testing the template first with a few sample references will allow pinpointing what element(s) in the template may need to be corrected.

As for your last question as to why the “Review of” phrase appears for selected references is probably due to the presence of the “link adjacent text” code • which may link either the Title or the Journal. It’s difficult to determine this from your example would be easier if there’s a screenshot of the output style template.  However the idea of the link to adjacent text code is if there’s info concerning the Title or Journal, the phrase “Review of” will or will not appear.

  

Thanks very much!

But what do you mean by testing? This is exactly the line I put in the template. It works fine except for papers which do not have any page numbers. There it shows the pp. (where it shouldn’t).

The review bit is not really a problem. I just wondered why it works the way it does. 

By “testing” I was referring to creating a few sample EndNote reference types.  These “test” references enable seeing how the output style template formats the sample references and in turn help identify if there’s one or more problems with the template. (So for example, creating sample references with/without page numbers, or where some of the field names are missing.)

If the “pp.” appears when there are no page numbers present, you should check the template to see if a “link adjacent” text is present to connect it to the Pages field like this: pp.•Pages

I don’t know what output style you’re using so this example is based on the APA 6th.  Refer to the attached image which shows the Book Section template.  Notice the link to adjacent text command that links “pp.” with “Pages”.  This instructs EndNote to insert pp. when page numbers are present in the Pages field.  But if pp. is appearing when there are no page numbers, it may be due to the lack of having the link adjacent text code.  To insert the code, click the INSERT FIELD button then select LINK ADJACENT TEXT.

Thanks! That does indeed solve it. Although I have to say that I don’t quite understand the general functionality of the field “link adjacent text” yet. What’s it for? What does the linking of text in the reference type have to do with field being “printed” on screen optionally? But anyways. 

More importantly: assume I have a paper with only one page. How do I tell endnote to have output p. if there is a single page and pp. if there are multiple pages? 

PS: I of course did run the template on text–otherwise I could not have reported to problem. I used a modified Chicago style.
PPS: Since you were so helpful with this one, do you have any idea on this by any chance? dash in bibliography // I also attached a screenshot of the reference types. Maybe that helps. 

 

p.^pp. will adjust single vs plural forms. 

The link character is so endnote knows that all the text between the "|"s (separate text) are one set.  if there is a regular space then it isn’t a continuous set and endnote doesn’t know tht the pp. parts are “linked” to the field “Pages” and should only be included if there are pages to be included.  – clear as mud? lol 

@suspekt wrote:

 PPS: Since you were so helpful with this one, do you have any idea on this by any chance? dash in bibliography // I also attached a screenshot of the reference types. Maybe that helps. 

 

Unfortunately this may be a programming issue for the developers and may not be addressable by the users.  Since you mentioned in you other post encountering inconsistent results after applying the latest patch it might be better to notify tech support directly rather than the user forum.  Contact tech support at:  http://www.endnote.com/support/entechform.asp

That was good advice. Did contact them. Here’s the solution: I hadn’t realized that some of the entries for the same author did not have the full first name (but only the initial). Therefore Endnote treated them as different authors. Simple as that.